Fórum dos Fóruns

Fórum dos Fóruns Forumeiros

Welcome FdF Bem-vindo ao fórum de suporte Forumeiros  Muito feliz


Para aproveitar tudo o que o nosso fórum lhe oferece, agradecemos que se identifique, se já é nosso membro, ou que se junte à nossa comunidade, fazendo o seu registo.
Acesso rápido

Fóruns de suporte oficiais


Pesquisa de Satisfação
Queremos saber a sua opinião sobre os nossos serviços. Clique nesta vinheta e preencha este inquérito.

Login

Esqueci minha senha

Últimos assuntos
» Remover cores da categoria e do menu iniciar
Hoje à(s) 23:44 por xBreninho_.

» Problema com Creditos
Hoje à(s) 23:39 por RT Detona

» Mensagem automática
Hoje à(s) 23:10 por Appoloz

» Versão mais avançada
Hoje à(s) 22:51 por David Silva

» Ranks Pokémon Continuação
Hoje à(s) 22:51 por ZamasuBR

» Descrição da categoria
Hoje à(s) 22:48 por Luiz~

» Ranks Pokémon
Hoje à(s) 21:09 por Maori

Perdi minha senha!
Obter senha

Nota: use se tiver perdido acesso ao seu painel de controle.

Magazine 2016
Participe da pesquisa de satisfação 2016 e dê sua opinião sobre os diversos serviços de Forumeiros.
Parceiros Forumeiros
Quem está conectado
192 usuários online :: 9 usuários cadastrados, Nenhum Invisível e 183 Visitantes :: 1 Motor de busca

Anderson_WondeR, Comensal, David Silva, Harleen, iScroll, Maori, RT Detona, Wamki, xBreninho_.

[ Ver toda a lista ]


O recorde de usuários online foi de 3131 em Qui 24 Dez 2009 - 15:05

Javascript funciona apenas na página inicial

Ver o tópico anterior Ver o tópico seguinte Ir em baixo

Resolvido Javascript funciona apenas na página inicial

Mensagem por Troubleshoot em Seg 19 Out 2015 - 17:28

Detalhes da questão


Endereço do fórum: http://www.cicacenter.com.br/
Versão do fórum: PunBB

Descrição


Olá! Muito feliz
As páginas do meu fórum ultrapassam o limite de resolução, o problema acontece em qualquer página menos no */portal.
Tentei reduzir o CSS de todas as #divs adicionais para um tamanho que se adapta-se a qualquer resolução do monitor, o problema é que em todas as páginas a resolução ultrapassa o limite e somente no portal a resolução fica correta.

Portal:

Outras páginas:


Edit*
O problema acontece no Javascript para fazer o efeito de submenu, no menu. O código JS funciona normalmente na index do fórum, já em outras páginas o código não surge efeito e a resolução do monitor ultrapassa o limite do width.

Alguma solução? Feliz


Última edição por Troubleshoot em Qui 22 Out 2015 - 13:08, editado 1 vez(es)

Troubleshoot
Usuário experiente

Masculino
Inscrito dia : 25/09/2011
Mensagens : 2168
Pontos Ativos : 4837

http://guiatecnico.ativo-forum.com/

Resolvido Re: Javascript funciona apenas na página inicial

Mensagem por Fraise em Seg 19 Out 2015 - 17:37

Olá!

Que tal fazermos isso pelo painel de controle? Aceda a Painel de Controle > Geral > Fórum > Configuração e em "Largura do fórum" coloque o valor que lhe agradar.

Até mais.
Fraise

Fraise
Super usuário

Masculino
Inscrito dia : 26/06/2015
Mensagens : 4973
Pontos Ativos : 7198

http://ajuda.forumeiros.com/ https://twitter.com/@FraiseFdF

Resolvido Re: Javascript funciona apenas na página inicial

Mensagem por Troubleshoot em Seg 19 Out 2015 - 18:58

Olá Fraise, como vai?
Então, eu já fiz este procedimento tentando alterar o valor em px,% e auto. Também já alterei o valor das #divs pelo CSS e todas estão com um limite padrão de 84% e min-width: 76%. Será que devo usar @mediaqueries?

Como já citei, o /portal fica com a resolução correta em qualquer monitor, já outras páginas ultrapassam o limite.



Troubleshoot
Usuário experiente

Masculino
Inscrito dia : 25/09/2011
Mensagens : 2168
Pontos Ativos : 4837

http://guiatecnico.ativo-forum.com/

Resolvido Re: Javascript funciona apenas na página inicial

Mensagem por Shek Crowley em Ter 20 Out 2015 - 3:07

Olá e bom dia.

Você tem algum elemento HTML adicionado no fórum, que, está invisível e está posicionado de forma incorreta para Direita. Segue a imagem:


http://i21.servimg.com/u/f21/18/76/69/60/20-10-10.png

Pelo que percebi, provavelmente pode ser um player de rádio... Ou não. Hm...

Eu não consigo encontrar o local que ele está adicionado... Errado

Atenciosamente,
Shek Rose

Tópico movido de 'Questões sobre a aparência do fórum' para 'Questões sobre códigos'


Atenciosamente,
Shek Crowley - Gerente voluntário de comunidade
A serviço de FORUMEIROS.com
Site: www.forumeiros.com
Contato: suporte:@:shiftactif.com

Shek Crowley
Admineiro
Admineiro

Masculino
Inscrito dia : 11/04/2009
Mensagens : 15409
Pontos Ativos : 22747

http://www.shiftactif.com https://www.facebook.com/shek.crowley https://twitter.com/shek_forumactif

Resolvido Re: Javascript funciona apenas na página inicial

Mensagem por Troubleshoot em Ter 20 Out 2015 - 13:37

Grande Shek Muito feliz
O problema acontece no JS para fazer a função de submenu, no menu. Tentei adicionar o código no antes do </head> e ele funciona normalmente na index do fórum, já quando tento ir em outras páginas o código não funciona... Louco

Por que isto acontece?

Troubleshoot
Usuário experiente

Masculino
Inscrito dia : 25/09/2011
Mensagens : 2168
Pontos Ativos : 4837

http://guiatecnico.ativo-forum.com/

Resolvido Re: Javascript funciona apenas na página inicial

Mensagem por Shek Crowley em Ter 20 Out 2015 - 14:50

Bom dia.

Isso depende. Se você colocou este código no template overall_header.tpl, ele vai funcionar em todas as páginas. Se seu código estiver com alguma definição para funcionamento em local específico, acredito que terás problemas. Triste

Até mais!


Atenciosamente,
Shek Crowley - Gerente voluntário de comunidade
A serviço de FORUMEIROS.com
Site: www.forumeiros.com
Contato: suporte:@:shiftactif.com

Shek Crowley
Admineiro
Admineiro

Masculino
Inscrito dia : 11/04/2009
Mensagens : 15409
Pontos Ativos : 22747

http://www.shiftactif.com https://www.facebook.com/shek.crowley https://twitter.com/shek_forumactif

Resolvido Re: Javascript funciona apenas na página inicial

Mensagem por Troubleshoot em Ter 20 Out 2015 - 15:43

Boa tarde!
O código HTML do menu está no overall_header depois do <body>, o CSS na Folha de estilo e o JS antes do </head>. No portal o código funciona normalmente, e em outras páginas do fórum o código não funciona.

Já tentei adicionar o código JS em "Gestão dos códigos Javascript" selecionando a opção 'Em todas páginas' ou local específico para funcionamento.


No tema anterior, utilizei o mesmo código para a opção de submenu em HTML e o código também 'bugava' em outras páginas do fórum.  
Estranho isso, não?

Troubleshoot
Usuário experiente

Masculino
Inscrito dia : 25/09/2011
Mensagens : 2168
Pontos Ativos : 4837

http://guiatecnico.ativo-forum.com/

Resolvido Re: Javascript funciona apenas na página inicial

Mensagem por Troubleshoot em Qui 22 Out 2015 - 13:09

Acredito que se passaram 24h, então.. UP Muito feliz
Ajuda/Confuso

Troubleshoot
Usuário experiente

Masculino
Inscrito dia : 25/09/2011
Mensagens : 2168
Pontos Ativos : 4837

http://guiatecnico.ativo-forum.com/

Resolvido Re: Javascript funciona apenas na página inicial

Mensagem por Troubleshoot em Dom 25 Out 2015 - 23:03

2º UP!
Alguém pode ajudar?

Troubleshoot
Usuário experiente

Masculino
Inscrito dia : 25/09/2011
Mensagens : 2168
Pontos Ativos : 4837

http://guiatecnico.ativo-forum.com/

Resolvido Re: Javascript funciona apenas na página inicial

Mensagem por Shek Crowley em Seg 26 Out 2015 - 2:33

Olá!

O problema é que não consigo encontrar o código. Se for um script que cria essa DIV, você precisa nos informar qual é ela. Pois, no código fonte ela me aparece vazia, e nem se quer existe em seus scripts.


Atenciosamente,
Shek Crowley - Gerente voluntário de comunidade
A serviço de FORUMEIROS.com
Site: www.forumeiros.com
Contato: suporte:@:shiftactif.com

Shek Crowley
Admineiro
Admineiro

Masculino
Inscrito dia : 11/04/2009
Mensagens : 15409
Pontos Ativos : 22747

http://www.shiftactif.com https://www.facebook.com/shek.crowley https://twitter.com/shek_forumactif

Resolvido Re: Javascript funciona apenas na página inicial

Mensagem por Troubleshoot em Seg 26 Out 2015 - 10:57

Olá @Shek, bom dia!
Código utilizado para o submenu:
(É possível deixar o código em apenas um <script></script>?)

Código:

   <script type="text/javascript">
jQuery(document).ready(function(){jQuery("#subm4").appendTo("li#nav_app_subm4(a[href$='/acessorios'])")});

</script>
      <script type="text/javascript">jQuery(document).ready(function(){jQuery("#subm1").appendTo("li#nav_app_m1(a[href$='/som'])")});</script>
   <script type="text/javascript">jQuery(document).ready(function(){jQuery("#subm3").appendTo("li#nav_app_subm3(a[href$='/pneus'])")});</script>
   <script type="text/javascript">jQuery(document).ready(function(){jQuery("#subm2").appendTo("li#nav_app_m2(a[href$='/rodas'])")});</script>
  
HTML:
Código:

 <div id="subm1">
                  <a href="/">Player</a> <a href="/">Multimídia</a><a href="/">DVD</a><a href="/h4-modulos-amplificadores">Módulos Amplificadores</a>  <a href="/">Sub Woofers</a> <a href="/">Acessórios para Som</a>    
      </div>
    <div id="subm2">
               <a href="/">BRW</a> <a href="/">TSW</a><a href="/">Vaska</a> <a href="/">Kromma</a> <a href="/">U.S Wheel</a>    <a href="/">Infinity Racing</a> <a href="/h6-Volcano-Wheels">Volcano Wheels</a> <a href="/">Scorro</a> <a href="/">KR-Wheels</a> <a href="/">Cosmos Wheels</a>
   </div>
    <div id="subm3">
             <a href="/">DELINTE</a>  <a href="/">Aro 14</a> <a href="/">Aro 15</a><a href="/">Aro 16</a> <a href="/">Aro 17</a> <a href="/">Aro 18</a>    <a href="/">Aro 19</a> <a href="/">Aro 20</a> <a href="/">Semi Novos</a>
   </div>
    <div id="subm4">
               <a href="/">Alarmes</a> <a href="/">Travas</a><a href="/">Vidros elétricos</a> <a href="/">Insulfilm Plotagem</a> <a href="/">Filtro cônico</a> <a href="/">Molas esportivas</a>  <a href="/">Lampadas</a> <a href="/">Tapetes</a><span style="color: #000000;font-family: cursive;font-size: 14px;/* font-weight: bolder; */"><div align="center"><strong>PARA SUA CAMINHONETE &gt;</strong></div></span>  <a href="/">Santo Antônio</a> <a href="/">Stribo</a> <a href="/">Capotas Maritimas</a>
   </div>

Troubleshoot
Usuário experiente

Masculino
Inscrito dia : 25/09/2011
Mensagens : 2168
Pontos Ativos : 4837

http://guiatecnico.ativo-forum.com/

Resolvido Re: Javascript funciona apenas na página inicial

Mensagem por Troubleshoot em Ter 27 Out 2015 - 13:13

Acredito que este problema esteja em meu fórum e não em códigos.
@Shek, pode visualizar meu fórum e ver se a algum erro de script?

Até mais.

Troubleshoot
Usuário experiente

Masculino
Inscrito dia : 25/09/2011
Mensagens : 2168
Pontos Ativos : 4837

http://guiatecnico.ativo-forum.com/

Resolvido Re: Javascript funciona apenas na página inicial

Mensagem por Troubleshoot em Qui 29 Out 2015 - 18:37

@UP!
:help:

Troubleshoot
Usuário experiente

Masculino
Inscrito dia : 25/09/2011
Mensagens : 2168
Pontos Ativos : 4837

http://guiatecnico.ativo-forum.com/

Resolvido Re: Javascript funciona apenas na página inicial

Mensagem por Shaman em Sex 30 Out 2015 - 3:53

Apague o código JavaScript que o senhor está usando, e crie um novo JavaScript em:

Painel de controle >> Módulos >> HTML e JavaScript >> Gestão dos códigos JavaScript >> Criar um novo JavaScript

E com o seguinte código:

Código:
jQuery(document).ready(function(){jQuery("#subm4").appendTo("li#nav_app_subm4(a[href$='/acessorios'])")});
jQuery(document).ready(function(){jQuery("#subm1").appendTo("li#nav_app_m1(a[href$='/som'])")});
jQuery(document).ready(function(){jQuery("#subm3").appendTo("li#nav_app_subm3(a[href$='/pneus'])")});
jQuery(document).ready(function(){jQuery("#subm2").appendTo("li#nav_app_m2(a[href$='/rodas'])")});

Em Investimento: coloque em todas as páginas!

Abs.

Shaman
Membro do Fórum

Masculino
Inscrito dia : 30/01/2014
Mensagens : 1784
Pontos Ativos : 3535

http://www.nexplorer.tk https://www.facebook.com/https://www.facebook.com/pages/Nexplorer/857666487628799?fref=ts

Resolvido Re: Javascript funciona apenas na página inicial

Mensagem por Troubleshoot em Sex 30 Out 2015 - 10:45

@Shaman escreveu:Apague o código JavaScript que o senhor está usando, e crie um novo JavaScript em:

Painel de controle >> Módulos >> HTML e JavaScript >> Gestão dos códigos JavaScript >> Criar um novo JavaScript

E com o seguinte código:

Código:
jQuery(document).ready(function(){jQuery("#subm4").appendTo("li#nav_app_subm4(a[href$='/acessorios'])")});
jQuery(document).ready(function(){jQuery("#subm1").appendTo("li#nav_app_m1(a[href$='/som'])")});
jQuery(document).ready(function(){jQuery("#subm3").appendTo("li#nav_app_subm3(a[href$='/pneus'])")});
jQuery(document).ready(function(){jQuery("#subm2").appendTo("li#nav_app_m2(a[href$='/rodas'])")});

Em Investimento: coloque em todas as páginas!

Abs.

Obrigado @Shaman!
Adicionei o código e continua não pegando em outras páginas do fórum...

Troubleshoot
Usuário experiente

Masculino
Inscrito dia : 25/09/2011
Mensagens : 2168
Pontos Ativos : 4837

http://guiatecnico.ativo-forum.com/
  • 0

Resolvido Re: Javascript funciona apenas na página inicial

Mensagem por MateusAnjosV em Sex 30 Out 2015 - 12:23

Bom dia @Troubleshoot

E se limitarmos assim?
Código:
body {overflow-x: hidden !important;max-width: 1400px !important}

MateusAnjosV
Membro do Fórum

Masculino
Inscrito dia : 16/10/2015
Mensagens : 1417
Pontos Ativos : 2440

http://ajuda.forumeiros.com/

Resolvido Re: Javascript funciona apenas na página inicial

Mensagem por Troubleshoot em Sex 30 Out 2015 - 14:22

@MateusAnjosV escreveu:Bom dia @Troubleshoot

E se limitarmos assim?
Código:
body {overflow-x: hidden !important;max-width: 1400px !important}
Bom dia!
Não pensei em limitar o body, mas resultou Feliz

O problema agora é com o Javascript, que não funciona em outras páginas do fórum somente no portal.

Alguma solução?

Troubleshoot
Usuário experiente

Masculino
Inscrito dia : 25/09/2011
Mensagens : 2168
Pontos Ativos : 4837

http://guiatecnico.ativo-forum.com/

Resolvido Re: Javascript funciona apenas na página inicial

Mensagem por Troubleshoot em Seg 2 Nov 2015 - 21:52

...
Alguém???

Troubleshoot
Usuário experiente

Masculino
Inscrito dia : 25/09/2011
Mensagens : 2168
Pontos Ativos : 4837

http://guiatecnico.ativo-forum.com/

Resolvido Re: Javascript funciona apenas na página inicial

Mensagem por MateusAnjosV em Seg 2 Nov 2015 - 21:55

Eu sinceramente não entendo pra que tanto ready...
Código:

  <script type="text/javascript">
jQuery(document).ready(function(){jQuery("#subm4").appendTo("li#nav_app_subm4(a[href$='/acessorios'])")});

</script>
      <script type="text/javascript">jQuery(document).ready(function(){jQuery("#subm1").appendTo("li#nav_app_m1(a[href$='/som'])")});</script>
  <script type="text/javascript">jQuery(document).ready(function(){jQuery("#subm3").appendTo("li#nav_app_subm3(a[href$='/pneus'])")});</script>
  <script type="text/javascript">jQuery(document).ready(function(){jQuery("#subm2").appendTo("li#nav_app_m2(a[href$='/rodas'])")});</script>
 

Para começar, substitua por esse:
Código:

  <script type="text/javascript">
jQuery(document).ready(function(){jQuery("#subm4").appendTo("li#nav_app_subm4(a[href$='/acessorios'])");
jQuery("#subm1").appendTo("li#nav_app_m1(a[href$='/som'])");
jQuery("#subm3").appendTo("li#nav_app_subm3(a[href$='/pneus'])");
jQuery("#subm2").appendTo("li#nav_app_m2(a[href$='/rodas'])")
});</script>
 

Segundo... onde você aplica esse script? Porque, se aplica nos javascripts normais com a tag script, não deveria funcionar em lugar algum. Você o aplica nos widgets?


MateusAnjosV
Membro do Fórum

Masculino
Inscrito dia : 16/10/2015
Mensagens : 1417
Pontos Ativos : 2440

http://ajuda.forumeiros.com/

Resolvido Re: Javascript funciona apenas na página inicial

Mensagem por Troubleshoot em Seg 2 Nov 2015 - 22:07

@MateusAnjosV
Adicionei o código no template, antes do </head>. Apliquei o seu código em um JS e não resultou... continua apenas o efeito no portal

Troubleshoot
Usuário experiente

Masculino
Inscrito dia : 25/09/2011
Mensagens : 2168
Pontos Ativos : 4837

http://guiatecnico.ativo-forum.com/

Resolvido Re: Javascript funciona apenas na página inicial

Mensagem por Troubleshoot em Ter 3 Nov 2015 - 15:51

Após eu editar o template consegui fazer com que o código funciona-se em qualquer página.
Obrigado pela ajuda de todos Feliz

@closed

Troubleshoot
Usuário experiente

Masculino
Inscrito dia : 25/09/2011
Mensagens : 2168
Pontos Ativos : 4837

http://guiatecnico.ativo-forum.com/

Resolvido Re: Javascript funciona apenas na página inicial

Mensagem por Fraise em Ter 3 Nov 2015 - 19:17

Questão marcada como Resolvida ou o Autor solicitou que ela fosse arquivada.

Tópico marcado como Resolvido e movido para "Questões resolvidas".

Fraise
Super usuário

Masculino
Inscrito dia : 26/06/2015
Mensagens : 4973
Pontos Ativos : 7198

http://ajuda.forumeiros.com/ https://twitter.com/@FraiseFdF

Ver o tópico anterior Ver o tópico seguinte Voltar ao Topo

- Tópicos similares

Permissão deste fórum:
Você não pode responder aos tópicos neste fórum