[Bug]"Reputação da mensagem: s% (100 votos)"

Ver o tópico anterior Ver o tópico seguinte Ir em baixo

Resolvido [Bug]"Reputação da mensagem: s% (100 votos)"

Mensagem por TOH em 16/02/10, 09:16 pm

Não sei se estou postando na seção certa, pois acho que isso se encaixaria mais na seção "Necessidade de um técnico"... mas como não posso postar lá, resolvi colocar aqui. A questão é a seguinte: quando alguém adiciona reputação a usuário no fórum, surge aquela barrinha verde no canto superior direito do post. Se pararmos o cursor do mouse sobre essa barra por alguns segundos aparece uma mensagem dizendo quantos usuários já adicionaram ou retiraram reputação. Acontece que a mensagem tem o seguinte formato: "Reputação da mensagem: s% (100 votos)" quando na verdade deveria ser: "Reputação da mensagem: y % (x votos)" onde y é a porcentagem de votos e x é o número de votos, ou seja, de pessoas que adicionaram reputação. O mais estranho é que esse bug parece ser apenas dos fóruns em português, pois percorri alguns fóruns de ajuda internacionais e vi que isso não ocorre. Gostaria muito que esse bug fosse corrigido, pois me parece uma coisa simples e talvez tenha sido algum problema na tradução da mensagem, ou coisa assim. Desde já agradeço a paciência em ler esse post extenso.
avatar

TOH
Usuário avançado

Masculino
Inscrito dia : 11/11/2007
Mensagens : 375
Pontos Ativos : 188

Ver perfil do usuário http://ajuda.forumeiros.com

Resolvido Re: [Bug]"Reputação da mensagem: s% (100 votos)"

Mensagem por TOH em 17/02/10, 08:59 pm

Alguém do staff poderia me dar uma posição sobre isso??

Grato.
avatar

TOH
Usuário avançado

Masculino
Inscrito dia : 11/11/2007
Mensagens : 375
Pontos Ativos : 188

Ver perfil do usuário http://ajuda.forumeiros.com

Resolvido Re: [Bug]"Reputação da mensagem: s% (100 votos)"

Mensagem por TOH em 18/02/10, 11:10 pm

up
avatar

TOH
Usuário avançado

Masculino
Inscrito dia : 11/11/2007
Mensagens : 375
Pontos Ativos : 188

Ver perfil do usuário http://ajuda.forumeiros.com
  • 0

Resolvido Re: [Bug]"Reputação da mensagem: s% (100 votos)"

Mensagem por Solkis em 16/03/10, 06:53 pm

Boa noite,

Este problema já se encontra resolvido, somente não foi colocado no ar, será junto com a próxima atualização! Eu mesmo fiz essa correção faz algum tempo, vou explicar do que se tratava o problema:

O sistema Forumeiros existe em vários idiomas, para cada um existe uma tradução (óbvio) e justo para o português, na época a Nêga, fez uma tradução errada! Existe um caractere chave, que é substituído pelos valores, que no caso é %s! Por exemplo o sistema de auto-inscrição:
Sim (%s mensagens)
Está assim no sistema e vocês veem o número de mensagens! Foi um erro com isso, faltou a correção do %s!

Até mais.


Tópico movido de 'Questões sobre o painel de controle' para 'Arquivos: problema corrigidos'
avatar

Solkis
Principal contribuidor
Principal contribuidor

Masculino
Inscrito dia : 26/01/2008
Mensagens : 9983
Pontos Ativos : 12074

Ver perfil do usuário http://ajuda.forumeiros.com

Resolvido Re: [Bug]"Reputação da mensagem: s% (100 votos)"

Mensagem por Daniel Mendes em 17/03/10, 11:57 am

Olá!

Eu também reparei que tenho isso que o nosso amigo disse no primeiro tópico. Li a sua resposta Solkis, mas não compreendi muito bem.

Fico no aguardo, sem mais.
avatar

Daniel Mendes
Membro do Fórum

Masculino
Inscrito dia : 30/01/2010
Mensagens : 1164
Pontos Ativos : 1661

Ver perfil do usuário http://www.danielmendes.info

Ver o tópico anterior Ver o tópico seguinte Voltar ao Topo

- Tópicos similares

Permissão deste fórum:
Você não pode responder aos tópicos neste fórum