Problema com o código na menssagem

Ver o tópico anterior Ver o tópico seguinte Ir em baixo

Resolvido Problema com o código na menssagem

Mensagem por cyllaz em 13/11/10, 02:00 am

alguem poderia fazer esse codigo funcionar na menssagem
ele funciona corretamente na pagina HTML mas na menssagem não


Código:
<table border=1 width=400 height=auto cellspacing=0 cellspanding=0>
<tr>
    <td width="92" height="28"><img style="CURSOR: pointer" id="modelo_r3_c2" onclick=" document.getElementById('rmvb').style.display='block'; document.getElementById('mp4').style.display='none';" border="0" name="modelo_r3_c2" hspace="0" alt="" src="http://i66.servimg.com/u/f66/14/56/85/28/rmvb10.png" width="92" height="28"></td>
    <td width="95" height="28"><img style="CURSOR: pointer" id="modelo_r3_c3" onclick=" document.getElementById('rmvb').style.display='none'; document.getElementById('mp4').style.display='block';" border="0" name="modelo_r3_c3" hspace="0" alt="" src="http://i66.servimg.com/u/f66/14/56/85/28/mp410.png" width="95" height="28">
    <td background="http://i66.servimg.com/u/f66/14/56/85/28/espaao11.png">&nbsp</td>
  </tr>
<tr>
    <td colspan=3>

<div style="display:block;" id="rmvb">
Opção1
</div>

<div style="display:none;" id="mp4">
Opção2
</div>

</td></tr></table>


Última edição por uzumaki minato em 13/11/10, 12:34 pm, editado 1 vez(es)

cyllaz
Usuário destaque

Masculino
Inscrito dia : 28/11/2009
Mensagens : 890
Pontos Ativos : 1258

Ver perfil do usuário http://sparquitetura.livreforum.com/

Resolvido Re: Problema com o código na menssagem

Mensagem por Callie em 13/11/10, 08:09 am

Olá uzumaki minato,

Quanto está a escrever uma mensagem aparece em baixo várias opções (criar votação, adicionar anexos, etc.).

Procure por "Desativar códigos HTML nesta mensagem", veja se essa opção está desmarcada.

Até mais.
avatar

Callie
Principal contribuidor
Principal contribuidor

Feminino
Inscrito dia : 20/12/2009
Mensagens : 5007
Pontos Ativos : 7285

Ver perfil do usuário

Resolvido Re: Problema com o código na menssagem

Mensagem por cyllaz em 13/11/10, 12:33 pm

essa opção esta OK, aparece a estrutura mentada setinho, mas não funciona a função

Código:
onclick=" document.getElementById('rmvb').style.display='none'; document.getElementById('mp4').style.display='block';"

que era pra mudar de RMVB para MP4

Esfa função funciona corretamente em uma pagina HTML

cyllaz
Usuário destaque

Masculino
Inscrito dia : 28/11/2009
Mensagens : 890
Pontos Ativos : 1258

Ver perfil do usuário http://sparquitetura.livreforum.com/

Resolvido Re: Problema com o código na menssagem

Mensagem por cyllaz em 13/11/10, 10:31 pm

up

cyllaz
Usuário destaque

Masculino
Inscrito dia : 28/11/2009
Mensagens : 890
Pontos Ativos : 1258

Ver perfil do usuário http://sparquitetura.livreforum.com/
  • 0

Resolvido Re: Problema com o código na menssagem

Mensagem por Byte em 14/11/10, 09:43 pm

Olá uzumaki minato!

Nas mensagens do fórum, mesmo com o HTML ativado, não funciona nenhum tipo de script! Neste caso, o seu contém um Javascript dentro de um atributo("onclick").

Espero ter lhe ajudado uzumaki minato!
Byte
avatar

Byte
Membro do Fórum

Masculino
Inscrito dia : 12/02/2009
Mensagens : 1272
Pontos Ativos : 2341

Ver perfil do usuário http://gabionicle.forum.st/

Resolvido Re: Problema com o código na menssagem

Mensagem por cyllaz em 14/11/10, 10:07 pm

Entendo, é uma pena, mas muito Obrigado Ajudou sim ^^

cyllaz
Usuário destaque

Masculino
Inscrito dia : 28/11/2009
Mensagens : 890
Pontos Ativos : 1258

Ver perfil do usuário http://sparquitetura.livreforum.com/

Ver o tópico anterior Ver o tópico seguinte Voltar ao Topo

- Tópicos similares

Permissão deste fórum:
Você não pode responder aos tópicos neste fórum