Redirecionamento do formulário

Ver o tópico anterior Ver o tópico seguinte Ir em baixo

Resolvido Redirecionamento do formulário

Mensagem por Yakushi Icefox em 19/12/10, 01:07 am

Olá.

Depois da mudança dos Links da Forumeiros, não consegui de geito nenhum fazer meus formulários funcionarem. Primeiramente, tentei adaptar o código antigo, tive sucesso em algumas áreas, porém em outras a página continuou a não ser redirecionada ao formulário. Soube que atualizaram o código do Tutorial. Testei o tal código em meu fórum, porém o resultado não foi animador: Quando se entra no fórum que "possui" um formulário, a página é direcionada para o "formulário de post" da Forumeiros (/post?f= ...). O formulário só é acionado se o usuário atualizar a página.

Código:
jQuery(document).ready(function() {
jQuery('a[href^="/post?f=41&mode=newtopic"]').attr('href', '/h9-');
jQuery('a[href^="/post?f=42&mode=newtopic"]').attr('href', '/h6-');
jQuery('a[href^="/post?f=40&mode=newtopic"]').attr('href', '/h10-');
jQuery('a[href^="/post?f=57&mode=newtopic"]').attr('href', '/h11-');
jQuery('a[href^="/post?f=24&mode=newtopic"]').attr('href', '/h12-');
jQuery('a[href^="/post?f=77&mode=newtopic"]').attr('href', '/h14-');
jQuery('a[href^="/post?f=93&mode=newtopic"]').attr('href', '/h13-');
jQuery('a[href^="/post?f=22&mode=newtopic"]').attr('href', '/h16-');
});

O número do fórum está correcto no código, e a página do formulário também está correta. Agradeço se alguém puder me dar um apoio.

Abraços.


Última edição por Yakushi Icefox em 20/12/10, 02:34 pm, editado 1 vez(es)
avatar

Yakushi Icefox
Nível 5

Masculino
Inscrito dia : 21/02/2010
Mensagens : 35
Pontos Ativos : 49

Ver perfil do usuário http://www.brasilplayforever.com/

Resolvido Re: Redirecionamento do formulário

Mensagem por Mikáá em 20/12/10, 08:58 am

Boa dia,
Defacto tem muitos tutoriais num só código 'botão' JQuery...
Mas surgio-me uma dúvida: Você antes desta atualização das urls conseguia meter os formulários funcionarem? Os formulários postavam nos tópicos onde você 'mandava' ?

Até mais
avatar

Mikáá
Hiperativo

Masculino
Inscrito dia : 13/02/2010
Mensagens : 3155
Pontos Ativos : 4009

Ver perfil do usuário https://www.facebook.com/amo.e.odeio

Resolvido Re: Redirecionamento do formulário

Mensagem por Yakushi Icefox em 20/12/10, 12:58 pm

SantolaZ escreveu:Boa dia,
Defacto tem muitos tutoriais num só código 'botão' JQuery...
Mas surgio-me uma dúvida: Você antes desta atualização das urls conseguia meter os formulários funcionarem? Os formulários postavam nos tópicos onde você 'mandava' ?

Até mais

Sim. Os formulários eram totalmente funcionais antes da Atualização das URLs da Forumeiros. O Problema começou quando a URL foi alterada, e houve necessidade de uma alteração no código.

Att.
avatar

Yakushi Icefox
Nível 5

Masculino
Inscrito dia : 21/02/2010
Mensagens : 35
Pontos Ativos : 49

Ver perfil do usuário http://www.brasilplayforever.com/

Resolvido Re: Redirecionamento do formulário

Mensagem por Byte em 20/12/10, 02:07 pm

Olá Yakushi Icefox!

Me registrei no seu fórum para verificar o problema, pois o código está perfeito, deveria funcionar...
Em choque
Antes de tudo fui verificar eu mesmo para ver se estava a funcionar, não encontrei problemas ao clicar no botão.
Então entrei em contato pelo chat com o moderador Pedro_ILPAN, e ele me disse que tinha terminado de testar e o código esta a funcionar normalmente agora. Que estava com alguns problemas um tempo atrás mas agora se ajeitaram. Eu somente verifiquei se o código que estava na hora em que falei com ele era o mesmo deste tópico.

O código está realmente certo! Algumas versões antigas do Firefox ainda tem alguns problemas para lerem códigos. Tente atualizar o seu Firefox para uma versão mais recente.
Positivo

Espero ter lhe ajudado Yakushi Icefox!
Byte
avatar

Byte
Membro do Fórum

Masculino
Inscrito dia : 12/02/2009
Mensagens : 1272
Pontos Ativos : 2341

Ver perfil do usuário http://gabionicle.forum.st/

Resolvido Re: Redirecionamento do formulário

Mensagem por Yakushi Icefox em 20/12/10, 02:34 pm

Olá, Byte.

Primeiramente, gostaria de pedir desculpas pelo transtorno que causei. Gostaria também de agradece-lo por ajudar-me.

Havia percebido que os usuários estavam conseguindo utilizar o formulário normalmente, então pensei que o problema fosse aqui.

E lendo sua resposta, lembrei-me que só havia testado o código no Firefox. Envergonhado Testei o Código no Opera e no IE, e o resultado foi positivo nestes navegadores.

Agradeço novamente. FdF de Parabéns, como sempre. E sim, pode ter certeza que ajudou-me.

Estarei demarcando o tópico como Resolvido.

Abraços,
Yaakushi_Icefox.
avatar

Yakushi Icefox
Nível 5

Masculino
Inscrito dia : 21/02/2010
Mensagens : 35
Pontos Ativos : 49

Ver perfil do usuário http://www.brasilplayforever.com/

Ver o tópico anterior Ver o tópico seguinte Voltar ao Topo

- Tópicos similares

Permissão deste fórum:
Você não pode responder aos tópicos neste fórum