Links com javascript pararam de funcionar

Ver o tópico anterior Ver o tópico seguinte Ir em baixo

Resolvido Links com javascript pararam de funcionar

Mensagem por jofre em 04/03/11, 01:58 pm

Qual é sua questão:
links do tipo

<a href="javascript:onClick=alert('Bom Dia');">Olá</a>

pararam de funcionar

ao passar o mouse por cima, não é possível clicar

o mesmo código que ainda funciona em posts mais antigos não tem o mesmo efeito nos novos

Que medidas você tomou para corrigir o problema:
pesquisei no fórum mas não encontrei nada relevante ao problema

Apresente-nos imagens do problema (se necessário):

jofre
Nível 6

Masculino
Inscrito dia : 22/09/2008
Mensagens : 61
Pontos Ativos : 87

Ver perfil do usuário

Resolvido Re: Links com javascript pararam de funcionar

Mensagem por Luciano98 em 04/03/11, 03:29 pm

Olá!

O certo é usar o Onclick fora do HREF:
<a href="#" onclick="alert('Bom dia!');return false">Olá</a>

Entendeu o problema?
Desse jeito funcionará Piscada

Até mais.
Luciano98.
avatar

Luciano98
Principal contribuidor
Principal contribuidor

Masculino
Inscrito dia : 01/09/2010
Mensagens : 7648
Pontos Ativos : 11045

Ver perfil do usuário http://ajuda.forumeiros.com

Resolvido Re: Links com javascript pararam de funcionar

Mensagem por jofre em 04/03/11, 06:40 pm

então

desse jeito, além de ter o inconveniente de enviar o usuário para o topo da página a cada clique, também não funciona

e não é possível usar "onclick" sem o "javascript:" antes

o melhor seria usar "javascript:void" no lugar do "#"

mas também não funciona

=(

o problema continua

REPITO: os tópicos antigos que estão EXATAMENTE da forma como descrevi ainda funcionam. O problema ocorre SOMENTE EM NOVOS POSTS ou quando tento realizar alguma alteração em posts já existentes.


jofre
Nível 6

Masculino
Inscrito dia : 22/09/2008
Mensagens : 61
Pontos Ativos : 87

Ver perfil do usuário

Resolvido Re: Links com javascript pararam de funcionar

Mensagem por Luciano98 em 04/03/11, 07:06 pm

@jofre escreveu:então

desse jeito, além de ter o inconveniente de enviar o usuário para o topo da página a cada clique, também não funciona

e não é possível usar "onclick" sem o "javascript:" antes

o melhor seria usar "javascript:void" no lugar do "#"

mas também não funciona

=(

o problema continua

REPITO: os tópicos antigos que estão EXATAMENTE da forma como descrevi ainda funcionam. O problema ocorre SOMENTE EM NOVOS POSTS ou quando tento realizar alguma alteração em posts já existentes.
Não mesmo, colocando ";return false" no final do "onclick" não envia o usuário para cima da página!
O onclick não precisa do "javascript:" para funcionar.

Faça um teste no seu site, primeiro teste, depois fale se funcionou:
<a href="#" onclick="alert('Bom dia!');return false">Bom dia</a>

Até mais.
avatar

Luciano98
Principal contribuidor
Principal contribuidor

Masculino
Inscrito dia : 01/09/2010
Mensagens : 7648
Pontos Ativos : 11045

Ver perfil do usuário http://ajuda.forumeiros.com

Resolvido Re: Links com javascript pararam de funcionar

Mensagem por jofre em 04/03/11, 08:04 pm

copiei como você disse e colei no fórum

"<a href="#" onclick="alert('Bom dia!');return false">Bom dia</a>"

não acontece nada quando clico

infelizmente, o problema continua

jofre
Nível 6

Masculino
Inscrito dia : 22/09/2008
Mensagens : 61
Pontos Ativos : 87

Ver perfil do usuário

Resolvido Re: Links com javascript pararam de funcionar

Mensagem por Luciano98 em 04/03/11, 08:09 pm

@jofre escreveu:copiei como você disse e colei no fórum

"<a href="#" onclick="alert('Bom dia!');return false">Bom dia</a>"

não acontece nada quando clico

infelizmente, o problema continua
Bem, o codigo está funcionando perfeitamente no meu computador.
Cuidado para não utilizar aspas("), assim o código pode não funcionar!

Poderia utilizar esse código no seu Fórum e me passar a página para eu ver se funciona aqui Interrogação

Até mais.
avatar

Luciano98
Principal contribuidor
Principal contribuidor

Masculino
Inscrito dia : 01/09/2010
Mensagens : 7648
Pontos Ativos : 11045

Ver perfil do usuário http://ajuda.forumeiros.com

Resolvido Re: Links com javascript pararam de funcionar

Mensagem por jofre em 06/03/11, 12:38 am

veja por si mesmo

além de não funcionar, ao clicar no link ele volta ao topo da página


http://audiobrasil.chocoforum.net/t1162-problema-js

jofre
Nível 6

Masculino
Inscrito dia : 22/09/2008
Mensagens : 61
Pontos Ativos : 87

Ver perfil do usuário

Resolvido Re: Links com javascript pararam de funcionar

Mensagem por Convidad em 06/03/11, 12:53 am

Bom dia,

Só para complementar! Usamos javascript:funcao() para chamar um função externa, e não para declarar eventos.

<script>function funcaoAbrir(){alert ('Bom dia');}</script>
<a href="javascript:funcaoAbrir()">Meu texto</a>


<a href="" onClick="alert('Bom dia!');">Meu texto</a>


Ou se prefir (no segundo caso em vermelho), remova o href=, ficando assim:
<a onClick="alert('Bom dia!');">Meu texto</a>[/color]

Você não precisa necessariamente deixar um href na tag A do html... Tem muito tempo que não trabalho com o Javascript raiz, por isso podem haver erros na sintase dos códigos acima, mais a tese foi explicada, com isso você entenderá...

Você compreende o que cada um faz?

Convidad
Convidado


Resolvido Re: Links com javascript pararam de funcionar

Mensagem por Luciano98 em 06/03/11, 01:03 am

@jofre escreveu:veja por si mesmo

além de não funcionar, ao clicar no link ele volta ao topo da página

http://audiobrasil.chocoforum.net/t1162-problema-js
Não consegui ver o link porque não sou cadastrado.

Você quer que funcione o HTML dos links em páginas normais do Fórum ou nos tópicos?

Tente fazer o que o Mr.Supero pediu para ver se resolve o problema.

Até mais.
Luciano98.
avatar

Luciano98
Principal contribuidor
Principal contribuidor

Masculino
Inscrito dia : 01/09/2010
Mensagens : 7648
Pontos Ativos : 11045

Ver perfil do usuário http://ajuda.forumeiros.com

Resolvido Re: Links com javascript pararam de funcionar

Mensagem por jofre em 06/03/11, 06:14 pm


Não consegui ver o link porque não sou cadastrado.

nesse caso, crie um cadastro

Você quer que funcione o HTML dos links em páginas normais do Fórum ou nos tópicos?

o que seriam "páginas normais"?

quero que funcione nos tópicos


problema continua


jofre
Nível 6

Masculino
Inscrito dia : 22/09/2008
Mensagens : 61
Pontos Ativos : 87

Ver perfil do usuário

Resolvido Re: Links com javascript pararam de funcionar

Mensagem por jofre em 06/03/11, 06:20 pm

Só para complementar! Usamos javascript:funcao() para chamar um função externa, e não para declarar eventos.

sim brother, no caso o script não estaria no tópico, está inserido no conjunto todo do portal (dentro de um widget)

o link apenas chamaria a função


Isso aqui:



<a href="" onClick="alert('Bom dia!');">Meu texto</a>

Ou se prefir (no segundo caso em vermelho), remova o href=, ficando assim:
<a onClick="alert('Bom dia!');">Meu texto</a>[/color]


também não funciona

pode conferir aqui: http://audiobrasil.chocoforum.net/t1162-problema-js#10110

(precisa se cadastrar)

por favor, queiram testar os códigos sugeridos antes de recomendar pq pelo que percebo, ninguém se deu ao trabalho de verificar antes de postar aqui

muito obrigado

jofre
Nível 6

Masculino
Inscrito dia : 22/09/2008
Mensagens : 61
Pontos Ativos : 87

Ver perfil do usuário

Resolvido Re: Links com javascript pararam de funcionar

Mensagem por Hancki em 06/03/11, 06:26 pm

Olá!

Tente isto:
Código:
<span onclick="javascript:alert('Janela');return false">Seu texto</span>
Até mais.
avatar

Hancki
Principal contribuidor
Principal contribuidor

Masculino
Inscrito dia : 03/10/2009
Mensagens : 8047
Pontos Ativos : 12032

Ver perfil do usuário http://programacaoweb.forumeiros.com/ https://www.facebook.com/djtomoficial https://www.facebook.com/djtomoficial

Resolvido Re: Links com javascript pararam de funcionar

Mensagem por jofre em 06/03/11, 06:36 pm

Olá!

Tente isto:

Código:
<span onclick="javascript:alert('Janela');return false">Seu texto</span>


Até mais.

isso aqui nem reconhece o texto como link - você realmente TESTOU aí e deu certo? Não




jofre
Nível 6

Masculino
Inscrito dia : 22/09/2008
Mensagens : 61
Pontos Ativos : 87

Ver perfil do usuário

Resolvido Re: Links com javascript pararam de funcionar

Mensagem por Hancki em 06/03/11, 06:38 pm

Pois não reconhece.
Eu criei desse modo para que o usuário não visse sempre sua página no topo ao clicar.
Mas você quer colocar isso num tópico (mensagem)?
avatar

Hancki
Principal contribuidor
Principal contribuidor

Masculino
Inscrito dia : 03/10/2009
Mensagens : 8047
Pontos Ativos : 12032

Ver perfil do usuário http://programacaoweb.forumeiros.com/ https://www.facebook.com/djtomoficial https://www.facebook.com/djtomoficial

Resolvido Re: Links com javascript pararam de funcionar

Mensagem por Luciano98 em 06/03/11, 06:39 pm

Olá!

Veja se o HTML nas mensagens esta ativados:
:seta3: Painel de Controle Seta Geral Seta Mensagens e e-mails Seta Configuração
Procure por "Permitir HTML :" e clique "Sim".

Até mais.
Luciano98.


Última edição por Luciano98 em 06/03/11, 06:41 pm, editado 1 vez(es)
avatar

Luciano98
Principal contribuidor
Principal contribuidor

Masculino
Inscrito dia : 01/09/2010
Mensagens : 7648
Pontos Ativos : 11045

Ver perfil do usuário http://ajuda.forumeiros.com

Resolvido Re: Links com javascript pararam de funcionar

Mensagem por jofre em 06/03/11, 06:40 pm

Veja se o HTML nas mensagens esta ativados:
Seta Painel de Controle Seta Geral Seta Mensagens e e-mails Seta Configuração
Procure por "Permitir HTML :" e clique "Sim".


claro que está ativo, amigo, caso contrário eu conseguiria ver o código, concorda?

Hancki, leia as mensagens postadas. já respondi a essa questão.


ainda preciso de ajuda, meu problema continua

gostaria, se possível, que alguém do próprio forumeiros respondesse

por favor, não responda caso você não tenha certeza de que o código sugerido realmente funciona nos fórums daqui.

muito obrigado

jofre
Nível 6

Masculino
Inscrito dia : 22/09/2008
Mensagens : 61
Pontos Ativos : 87

Ver perfil do usuário

Resolvido Re: Links com javascript pararam de funcionar

Mensagem por Hancki em 06/03/11, 06:51 pm

Olhe, teremos que complicar!
Use este código num widget:
Código:
<script src="http://code.jquery.com/jquery-1.5.js"></script>
<script>
 jQuery(document).ready(function(){
  jQuery("#bomdia").click(function(event){
    alert("Seu texto da janela");
  });
 });
</script>
E este código para que funcione em qualquer mensagem:
Código:
<a href="#" id="bomdia">Meu texto</a>
avatar

Hancki
Principal contribuidor
Principal contribuidor

Masculino
Inscrito dia : 03/10/2009
Mensagens : 8047
Pontos Ativos : 12032

Ver perfil do usuário http://programacaoweb.forumeiros.com/ https://www.facebook.com/djtomoficial https://www.facebook.com/djtomoficial

Resolvido Re: Links com javascript pararam de funcionar

Mensagem por jofre em 06/03/11, 07:11 pm

AEEEEE

agora eu vi vantagem!

esse funcionou!

é muito semelhante ao que estou fazendo


porém na hora do link chamar a função, o texto que deveria ser link, não é reconhecido como link e não fica clicável

bem, ao menos há uma luz no fim do túnel

vou experimentar, talvez seja o script inserido que está com algum problema

muito obrigado, hancki Piscada


jofre
Nível 6

Masculino
Inscrito dia : 22/09/2008
Mensagens : 61
Pontos Ativos : 87

Ver perfil do usuário

Resolvido Re: Links com javascript pararam de funcionar

Mensagem por jofre em 06/03/11, 07:46 pm

ao que tudo indica, alguma modificação foi feita que não permite mais links do tipo

<a href="javascript:função()"> nos posts

e parece ser algum tipo de validação que só começou a funcionar recentemente, já que eu usava esse formato há mais de 1 ano sem problemas

caso alguém saiba como desativar essa validação, fico agradecido

já que estou numa situação difícil aqui
os posts antigos que contém esse código funcionam sem problemas

porém não consigo criar novos posts com o mesmo código e obter o mesmo resultado

não vejo outra explicação

se tiver que alterar, vou ter que mexer em tópico por tópico - o que será um trabalho grande demais - por favor, me ajudem!

jofre
Nível 6

Masculino
Inscrito dia : 22/09/2008
Mensagens : 61
Pontos Ativos : 87

Ver perfil do usuário

Resolvido Re: Links com javascript pararam de funcionar

Mensagem por jofre em 07/03/11, 02:41 pm

ok, atualizando a situação

consegui resolver o problema usando jquery

obrigado novamente, Hancki

jofre
Nível 6

Masculino
Inscrito dia : 22/09/2008
Mensagens : 61
Pontos Ativos : 87

Ver perfil do usuário

Ver o tópico anterior Ver o tópico seguinte Voltar ao Topo

- Tópicos similares

Permissão deste fórum:
Você não pode responder aos tópicos neste fórum