Problema ao adicionar um google video num tópico

Ver o tópico anterior Ver o tópico seguinte Ir em baixo

Resolvido Problema ao adicionar um google video num tópico

Mensagem por grufalao em 21/06/11, 06:22 pm

Qual é sua questão:
Boas,

Antes de mais espero que esta seja a área adequada para este tipo de post.

O que se passa é seguinte preciso de colocar dentro de um tópico um google video. Eu coloco lá o embed tiro o visto da checkbox para "desactivar códigos html" e pré-visualizo. Ao prévisualizar funciona mas quando envio aparece-me só o código!

Já exprimentei utilizador o bbcode especifico do google video que é este [googlevideo][/googlevideo] . Mas o problema está no embed que não tem docid ???


O embed é este:


<embed src="http://www.youtube.com/get_player" type="application/x-shockwave-flash" flashvars="flvurl=http%3A%2F%2Fv13.nonxt5.googlevideo.com%2Fvideoplayback%3Fid%3Daaf641633dde2b12%26itag%3D5%26app%3Dblogger%26ip%3D0.0.0.0%26ipbits%3D0%26expire%3D1310498228%26sparams%3Did%252Citag%252Cip%252Cipbits%252Cexpire%26signature%3D479461BFA8DFE7930E017E0B7A045CAA5714547D.71A1A3EFDCF2744B2FA362722777B8CB67EDA555%26key%3Dck1&amp;iurl=http%3A%2F%2Fvideo.google.com%2FThumbnailServer2%3Fapp%3Dblogger%26contentid%3Daaf641633dde2b12%26offsetms%3D5000%26itag%3Dw160%26sigh%3Dpem5we8Pl9yknL_UHghQ8HMpqm8;" width="414" height="340"></object>


Se dá para pré-visualizar em embed tem que existir uma maneira para postar a funcionar só em bbcode como para um video do youtube, correcto?

Fico a aguardar resposta, obrigado.

Que medidas você tomou para corrigir o problema:
Pesquisei no google por embeds do google video que não tivessem docid para poder colocar dentro da tag bbcode [googlevideo] e não encontrei.

Mais uma vez repito que o embed funciona ao pré-visualizar no tópico mas ao enviar só mostra o código.

Apresente-nos imagens do problema (se necessário):


Qual o endereço de seu fórum:
http://www.fs-forum.net

Qual a versão de seu fórum?:
Phpbb3


Última edição por grufalao em 22/06/11, 03:36 pm, editado 4 vez(es)

grufalao
Nível 8

Masculino
Inscrito dia : 09/03/2008
Mensagens : 116
Pontos Ativos : 67

Ver perfil do usuário http://www.fs-forum.net

Resolvido Re: Problema ao adicionar um google video num tópico

Mensagem por Dury em 21/06/11, 07:53 pm

Olá,

Tens que certificar se o HTML do "Fórum" está ativo.
Painel de controle ->> Geral ->> Mensagens e Emails ->> Configuração ->>
Procure por "Permitir HTML" e marque "sim".

Leia este tópico caso precise de mais informações: http://ajuda.forumeiros.com/t41810-

Até mais!
Piscada
avatar

Dury
Principal contribuidor
Principal contribuidor

Masculino
Inscrito dia : 21/01/2009
Mensagens : 6708
Pontos Ativos : 8827

Ver perfil do usuário

Resolvido Re: Problema ao adicionar um google video num tópico

Mensagem por grufalao em 21/06/11, 08:05 pm

Olá,

O html já está activo em todo o fórum e mesmo assim não dá.. Tem é a haver com a maneira como se passa esse embed ai em cima para bbcode.

Esse link que me passas-te não serve porque acho só funciona com videos do youtube...

grufalao
Nível 8

Masculino
Inscrito dia : 09/03/2008
Mensagens : 116
Pontos Ativos : 67

Ver perfil do usuário http://www.fs-forum.net

Resolvido Re: Problema ao adicionar um google video num tópico

Mensagem por Dury em 21/06/11, 08:11 pm

Olá,

Não use o <embed> para isso, poderá colher apenas o endereço da página. Exemplo de endereço de vídeo:
http://www.youtube.com/watch?v=x5reet2CkV4&feature=player_profilepage

Clique em "Novo tópico" de seu fórum, e na caixinha mostrada abaixo, coloque o endereço:




Até mais!
Muito feliz
avatar

Dury
Principal contribuidor
Principal contribuidor

Masculino
Inscrito dia : 21/01/2009
Mensagens : 6708
Pontos Ativos : 8827

Ver perfil do usuário

Resolvido Re: Problema ao adicionar um google video num tópico

Mensagem por grufalao em 21/06/11, 08:18 pm

Você não está a entender..

Eu não posso fazer isso porque não se trata de um video do youtube mas sim um Google Video! Logo não posso proceder dessa forma.

Esse embed utiliza o player do youtube para reproduzir o video mas está armazenado na google videos ou algo do género.

grufalao
Nível 8

Masculino
Inscrito dia : 09/03/2008
Mensagens : 116
Pontos Ativos : 67

Ver perfil do usuário http://www.fs-forum.net

Resolvido Re: Problema ao adicionar um google video num tópico

Mensagem por Dury em 21/06/11, 08:21 pm

Olá,

Poderia nos passar o endereço do vídeo por favor?
avatar

Dury
Principal contribuidor
Principal contribuidor

Masculino
Inscrito dia : 21/01/2009
Mensagens : 6708
Pontos Ativos : 8827

Ver perfil do usuário

Resolvido Re: Problema ao adicionar um google video num tópico

Mensagem por grufalao em 21/06/11, 08:29 pm

Também eu gostava de saber como obter o link porque ele aparentemente está encriptado dentro do embed Triste

Eu no inicio andava atrapalhado porque também pensava que o video pertencia ao youtube mas não.. Esse video está num blog e eu fui ao código fonte do blog e extrai de lá o embed do video e não vejo maneira de aceder ao hyperlink do video.

De qualquer das maneiras aqui tens o link do blog com o vídeo:

-> http://forcasuprema4life.blogspot.com/2008/11/sntv-9.html


P.S.: Desce um bocado na página porque o Blog é comprido é o segundo video! O 1º não interessa esse é mesmo do youtube e está indisponivel.

grufalao
Nível 8

Masculino
Inscrito dia : 09/03/2008
Mensagens : 116
Pontos Ativos : 67

Ver perfil do usuário http://www.fs-forum.net

Resolvido Re: Problema ao adicionar um google video num tópico

Mensagem por Dury em 21/06/11, 08:38 pm

Infelizmente nos tópicos eu não consegui aplicar, como você. No etanto na mensagem da home page eu consegui:
Painel de controle ->> Visualização ->> Home Page ->> Geral ->> Conteúdo da mensagem ->>

Este é o código:
Código:
<object width="414" height="340" class="BLOG_video_class" id="BLOG_video-aaf641633dde2b12" classid="clsid:D27CDB6E-AE6D-11cf-96B8-444553540000" codebase="http://download.macromedia.com/pub/shockwave/cabs/flash/swflash.cab#version=6,0,40,0"><param name="movie" value="http://www.youtube.com/get_player">
<param name="bgcolor" value="#FFFFFF">
<param name="allowfullscreen" value="true">
<param name="flashvars" value="flvurl=http%3A%2F%2Fv13.nonxt5.googlevideo.com%2Fvideoplayback%3Fid%3Daaf641633dde2b12%26itag%3D5%26app%3Dblogger%26ip%3D0.0.0.0%26ipbits%3D0%26expire%3D1310846484%26sparams%3Did%252Citag%252Cip%252Cipbits%252Cexpire%26signature%3D711D695291592A1BC1F731914358BB39885CF512.6CB00A2BCDF525E792734BD4B23B30FB147D9136%26key%3Dck1&amp;iurl=http%3A%2F%2Fvideo.google.com%2FThumbnailServer2%3Fapp%3Dblogger%26contentid%3Daaf641633dde2b12%26offsetms%3D5000%26itag%3Dw160%26sigh%3Dpem5we8Pl9yknL_UHghQ8HMpqm8&amp;autoplay=0&amp;ps=blogger">
<embed src="http://www.youtube.com/get_player" type="application/x-shockwave-flash"
width="414" height="340" bgcolor="#FFFFFF"
flashvars="flvurl=http%3A%2F%2Fv13.nonxt5.googlevideo.com%2Fvideoplayback%3Fid%3Daaf641633dde2b12%26itag%3D5%26app%3Dblogger%26ip%3D0.0.0.0%26ipbits%3D0%26expire%3D1310846484%26sparams%3Did%252Citag%252Cip%252Cipbits%252Cexpire%26signature%3D711D695291592A1BC1F731914358BB39885CF512.6CB00A2BCDF525E792734BD4B23B30FB147D9136%26key%3Dck1&iurl=http%3A%2F%2Fvideo.google.com%2FThumbnailServer2%3Fapp%3Dblogger%26contentid%3Daaf641633dde2b12%26offsetms%3D5000%26itag%3Dw160%26sigh%3Dpem5we8Pl9yknL_UHghQ8HMpqm8&autoplay=0&ps=blogger"
allowFullScreen="true" /></object>

Caso queira centrealizá-lo:
Código:
<center><object width="414" height="340" class="BLOG_video_class" id="BLOG_video-aaf641633dde2b12" classid="clsid:D27CDB6E-AE6D-11cf-96B8-444553540000" codebase="http://download.macromedia.com/pub/shockwave/cabs/flash/swflash.cab#version=6,0,40,0"><param name="movie" value="http://www.youtube.com/get_player">
<param name="bgcolor" value="#FFFFFF">
<param name="allowfullscreen" value="true">
<param name="flashvars" value="flvurl=http%3A%2F%2Fv13.nonxt5.googlevideo.com%2Fvideoplayback%3Fid%3Daaf641633dde2b12%26itag%3D5%26app%3Dblogger%26ip%3D0.0.0.0%26ipbits%3D0%26expire%3D1310846484%26sparams%3Did%252Citag%252Cip%252Cipbits%252Cexpire%26signature%3D711D695291592A1BC1F731914358BB39885CF512.6CB00A2BCDF525E792734BD4B23B30FB147D9136%26key%3Dck1&amp;iurl=http%3A%2F%2Fvideo.google.com%2FThumbnailServer2%3Fapp%3Dblogger%26contentid%3Daaf641633dde2b12%26offsetms%3D5000%26itag%3Dw160%26sigh%3Dpem5we8Pl9yknL_UHghQ8HMpqm8&amp;autoplay=0&amp;ps=blogger">
<embed src="http://www.youtube.com/get_player" type="application/x-shockwave-flash"
width="414" height="340" bgcolor="#FFFFFF"
flashvars="flvurl=http%3A%2F%2Fv13.nonxt5.googlevideo.com%2Fvideoplayback%3Fid%3Daaf641633dde2b12%26itag%3D5%26app%3Dblogger%26ip%3D0.0.0.0%26ipbits%3D0%26expire%3D1310846484%26sparams%3Did%252Citag%252Cip%252Cipbits%252Cexpire%26signature%3D711D695291592A1BC1F731914358BB39885CF512.6CB00A2BCDF525E792734BD4B23B30FB147D9136%26key%3Dck1&iurl=http%3A%2F%2Fvideo.google.com%2FThumbnailServer2%3Fapp%3Dblogger%26contentid%3Daaf641633dde2b12%26offsetms%3D5000%26itag%3Dw160%26sigh%3Dpem5we8Pl9yknL_UHghQ8HMpqm8&autoplay=0&ps=blogger"
allowFullScreen="true" /></object></center>

Até mais!
Muito feliz
avatar

Dury
Principal contribuidor
Principal contribuidor

Masculino
Inscrito dia : 21/01/2009
Mensagens : 6708
Pontos Ativos : 8827

Ver perfil do usuário

Resolvido Re: Problema ao adicionar um google video num tópico

Mensagem por grufalao em 21/06/11, 08:44 pm

Pois, mas eu queria isso a funcionar nos tópicos!


Se dá para pré-visualizar direito nos tópicos porque é que ao postar mostra-me o código em vez do vídeo?!

Fico à espera da resposta de mais alguém da equipe forumeiros para me puderem solucionar este problema.

Obrigado pelo esforço jeffrey

grufalao
Nível 8

Masculino
Inscrito dia : 09/03/2008
Mensagens : 116
Pontos Ativos : 67

Ver perfil do usuário http://www.fs-forum.net

Resolvido Re: Problema ao adicionar um google video num tópico

Mensagem por Dury em 21/06/11, 09:10 pm

Olá,

Eu não vou dessitir. Eu tinha olhado o código de novo, e observei essa parte:
Código:
<embed src="http://www.youtube.com/get_player" type="application/x-shockwave-flash" />

Teste-na para ver se resolve.
avatar

Dury
Principal contribuidor
Principal contribuidor

Masculino
Inscrito dia : 21/01/2009
Mensagens : 6708
Pontos Ativos : 8827

Ver perfil do usuário

Resolvido Re: Problema ao adicionar um google video num tópico

Mensagem por grufalao em 22/06/11, 07:58 am

Não isso não serve porque não tem referência para o link do google video que como eu já expliquei anteriormente parece estar encriptado. Esse código que me deste agora só mostra o player do youtube sem video.

Começo a pensar que aquele é um video privado e é por isso que não aparece o docid no embed.

Mas se dá para pré-visualizar direito voces tem que me disponibilizar uma opção em Bbcode que funcione!


Também funciona no portal só não está a dar dentro dos tópicos que era o que eu queria Triste

grufalao
Nível 8

Masculino
Inscrito dia : 09/03/2008
Mensagens : 116
Pontos Ativos : 67

Ver perfil do usuário http://www.fs-forum.net

Resolvido Re: Problema ao adicionar um google video num tópico

Mensagem por Dury em 22/06/11, 10:33 am

Olá,

Eu estou chegando á uma conclusão que não é possível. É, realmente ele aparece conforme você disse na pré-visualização mas o pior disto é que não é possível dar o "Play" no vídeo, ocorre um erro.

Outro pedido á você, é que não use formatações em fontes coloridas ou negrito, somente á equipe em situações designadas podem usá-las.
avatar

Dury
Principal contribuidor
Principal contribuidor

Masculino
Inscrito dia : 21/01/2009
Mensagens : 6708
Pontos Ativos : 8827

Ver perfil do usuário

Resolvido Re: Problema ao adicionar um google video num tópico

Mensagem por Mikáá em 22/06/11, 10:36 am

Se calhar tem o HTML desligado em seu fórum....
avatar

Mikáá
Hiperativo

Masculino
Inscrito dia : 13/02/2010
Mensagens : 3155
Pontos Ativos : 4009

Ver perfil do usuário https://www.facebook.com/amo.e.odeio
  • 0

Resolvido Re: Problema ao adicionar um google video num tópico

Mensagem por Luciano98 em 22/06/11, 02:37 pm

Olá!

O HTML pode estar desativado no seu perfil.
Perfil Seta Preferências
Procure por "Sempre permitir HTML :" e marque "Sim".

Outra coisa...
Esse codigo está errado.

O certo seria (teste esse código no tópico do seu fórum):
Código:
<embed src="http://youtube.com/get_player?flvurl=http%3A%2F%2Fv13.nonxt5.googlevideo.com%2Fvideoplayback%3Fid%3Daaf641633dde2b12%26itag%3D5%26app%3Dblogger%26ip%3D0.0.0.0%26ipbits%3D0%26expire%3D1310498228%26sparams%3Did%252Citag%252Cip%252Cipbits%252Cexpire%26signature%3D479461BFA8DFE7930E017E0B7A045CAA5714547D.71A1A3EFDCF2744B2FA362722777B8CB67EDA555%26key%3Dck1&amp;iurl=http%3A%2F%2Fvideo.google.com%2FThumbnailServer2%3Fapp%3Dblogger%26contentid%3Daaf641633dde2b12%26offsetms%3D5000%26itag%3Dw160%26sigh%3Dpem5we8Pl9yknL_UHghQ8HMpqm8" type="application/x-shockwave-flash" width=414 height=340></embed>

Até mais.
Luciano98.


Última edição por Luciano98 em 22/06/11, 05:16 pm, editado 2 vez(es)
avatar

Luciano98
Principal contribuidor
Principal contribuidor

Masculino
Inscrito dia : 01/09/2010
Mensagens : 7648
Pontos Ativos : 11045

Ver perfil do usuário http://ajuda.forumeiros.com

Resolvido Re: Problema ao adicionar um google video num tópico

Mensagem por grufalao em 22/06/11, 03:35 pm

Olá Jeffrey peço desculpa por ter utilizado as formatações com cores mas não sabia e era para ver se assim te ajudava mais a ir directo ao assunto. E já agora obrigado pelo teu apoio e esforço

Olá Luciano98 , obrigado resultou!!


Até mais! Muito feliz

grufalao
Nível 8

Masculino
Inscrito dia : 09/03/2008
Mensagens : 116
Pontos Ativos : 67

Ver perfil do usuário http://www.fs-forum.net

Ver o tópico anterior Ver o tópico seguinte Voltar ao Topo

- Tópicos similares

Permissão deste fórum:
Você não pode responder aos tópicos neste fórum