Alguém ajuda aqui

Ver o tópico anterior Ver o tópico seguinte Ir em baixo

Resolvido Alguém ajuda aqui

Mensagem por Troubleshoot em Sab 22 Out 2011 - 11:45

Qual é minha questão:
Estou com problema nos "prefixo" de [tag´s] no meu fórum , depois de um certo tempo ele parou de funcionar , estou usando este código:
Código:
;function tagprefixo(){jQuery('input[name=subject]').val(jQuery('select[name=tags4]').val()+jQuery('input[name=subject]').val())};jQuery(document).ready(function(){jQuery('#text_edit').before('<select name=tags4 onchange=tagprefixo()><option value="">(sem prefixo)</option><option value=[Anuncio]>Anúncio</option>
<option value=[Apresentacao]>Apresentação</option>
<option value=[CMS]>CMS</option>
<option value=[DB]>Databases</option>
<option value=[Download]>Download</option>
<option value=[Duvida]>Dúvida</option>
<option value=[Dica]>Dica</option>
<option value=[EMU]>Emulador</option>
<option value=[Evento]>Evento</option>
<option value=[Entrega]>Entrega</option>
<option value=[Filme]>Filme</option>
<option value=[Game]>Game</option>
<option value=[Imagem]>Imagem</option>
<option value=[Musica]>Música</option>
<option value=[Noticia]>Notícia</option>
<option value=[Offtopic]>Offtopic</option>
<option value=[Pedido]>Pedido</option>
<option value=[Piada]>Piadas</option>
<option value=[Recado]>Recado</option>
<option value=[Regras]>Regras</option>
<option value=[Sugestao]>Sugestão</option>
<option value=[Seriado]>Seriado</option>
<option value=[Tutorial]>Tutorial</option>
<option value=[Utilitario]>Utilitários</option>
<option value=[Video]>Vídeo</option></select>&nbsp<img src=http://illiweb.com/fa/wysiwyg/separator.png style=vertical-align:middle>&nbsp')});jQuery(document).ready(function(){var mode=jQuery('input[value=reply]').val();if(mode=='reply'){jQuery('select[name=tags4]').css('display','none')}else if(mode=='quote'){jQuery('select[name=tags4]').css('display','none')}});

Ele funcionava normalmente mas ai fui fazer um tópico no meu fórum e as "tag´s " não estavam ativas ....

Se alguém puder ajudar , agradeço

Medidas que eu tomei para corrigir o problema:
--

Imagens do meu problema:
--

Endereço do meu fórum:
http://rbforum.forumbrasil.net

Versão do meu fórum:
PHPBB3
avatar

Troubleshoot
Usuário experiente

Masculino
Inscrito dia : 25/09/2011
Mensagens : 2197
Pontos Ativos : 2940

Ver perfil do usuário http://guiatecnico.ativo-forum.com/

Resolvido Re: Alguém ajuda aqui

Mensagem por Convidad em Sab 22 Out 2011 - 15:39

Boa tarde autor!

Já tentou refazer esta função? Use o tutorial: http://ajuda.forumeiros.com/t46956-

Por descuido, algum co-administrador pode ter alterado algum valor no código ou nas localidades para que o mesmo seja ativado.

Convidad
Convidado


Resolvido Re: Alguém ajuda aqui

Mensagem por Troubleshoot em Sab 22 Out 2011 - 19:17

Já tentei , acho que o código ta "bugado" , depois de um certo tempo parou de funcionar e ninguém da minha equipe mexeu nele ...


Aguardo ..

att
avatar

Troubleshoot
Usuário experiente

Masculino
Inscrito dia : 25/09/2011
Mensagens : 2197
Pontos Ativos : 2940

Ver perfil do usuário http://guiatecnico.ativo-forum.com/

Resolvido Re: Alguém ajuda aqui

Mensagem por Luciano98 em Sab 22 Out 2011 - 19:18

Olá!

Teste esse código (não é preciso modificar nada):
Código:
;function tagprefixo(){jQuery('input[name=subject]').val(jQuery('select[name=tags4]').val()+jQuery('input[name=subject]').val())};jQuery(document).ready(function(){jQuery('#text_edit').before('<select name=tags4 onchange=tagprefixo()><option value="">(sem prefixo)</option><option value=[Anuncio]>Anúncio</option><option value=[Apresentacao]>Apresentação</option><option value=[CMS]>CMS</option><option value=[DB]>Databases</option><option value=[Download]>Download</option><option value=[Duvida]>Dúvida</option><option value=[Dica]>Dica</option><option value=[EMU]>Emulador</option><option value=[Evento]>Evento</option><option value=[Entrega]>Entrega</option><option value=[Filme]>Filme</option><option value=[Game]>Game</option><option value=[Imagem]>Imagem</option><option value=[Musica]>Música</option><option value=[Noticia]>Notícia</option><option value=[Offtopic]>Offtopic</option><option value=[Pedido]>Pedido</option><option value=[Piada]>Piadas</option><option value=[Recado]>Recado</option><option value=[Regras]>Regras</option><option value=[Sugestao]>Sugestão</option><option value=[Seriado]>Seriado</option><option value=[Tutorial]>Tutorial</option><option value=[Utilitario]>Utilitários</option><option value=[Video]>Vídeo</option></select>&nbsp<img src=http://illiweb.com/fa/wysiwyg/separator.png style=vertical-align:middle>&nbsp')});jQuery(document).ready(function(){var mode=jQuery('input[value=reply]').val();if(mode=='reply'){jQuery('select[name=tags4]').css('display','none')}else if(mode=='quote'){jQuery('select[name=tags4]').css('display','none')}});

Até mais.
avatar

Luciano98
Principal contribuidor
Principal contribuidor

Masculino
Inscrito dia : 01/09/2010
Mensagens : 7648
Pontos Ativos : 11045

Ver perfil do usuário http://ajuda.forumeiros.com

Resolvido Re: Alguém ajuda aqui

Mensagem por Troubleshoot em Sab 22 Out 2011 - 19:26

Obrigado Luciano98 , me ajudou muito !

Podem fechar

att
avatar

Troubleshoot
Usuário experiente

Masculino
Inscrito dia : 25/09/2011
Mensagens : 2197
Pontos Ativos : 2940

Ver perfil do usuário http://guiatecnico.ativo-forum.com/

Ver o tópico anterior Ver o tópico seguinte Voltar ao Topo

- Tópicos similares

Permissão deste fórum:
Você não pode responder aos tópicos neste fórum