Menu personalizado com problema

Ver o tópico anterior Ver o tópico seguinte Ir em baixo

Resolvido Menu personalizado com problema

Mensagem por Kojitani em 25/02/13, 07:44 am

Qual é minha questão:
Olá (bom dia),
No menu retrátil estou com um pequeno problema, faz dias que estou tentando arrumar e nada. Quando ele esta fechado a seta aparece normalmente. Porém, quando o menu abre, no local da seta, fica um quadrado com o fundo. Eu creio que ele não esteja visualizando a imagem quando aberto e fica o quadrado do fundo apenas.



alguém poderia me ajudar?

Endereço do meu fórum:
http://sobrevivencialistabr.forumeiros.com

Versão do fórum:
PHPBB3


Última edição por Kojitani em 26/02/13, 10:00 am, editado 2 vez(es)
avatar

Kojitani
Nível 9

Masculino
Inscrito dia : 02/02/2013
Mensagens : 173
Pontos Ativos : 257

Ver perfil do usuário http://sobrevivencialistabr.forumeiros.com

Resolvido Re: Menu personalizado com problema

Mensagem por seender em 25/02/13, 07:54 am

Olá!

Isso se dá pela mudança na estrutura da página, não há como corrigir, mas tente este código, talvez funcione:
Código:
#forum-widget{position:absolute !important;}
Leia e siga atentamente o tutorial, caso queira fazer novamente o efeito de modo correto como aqui no fórum dos fóruns: Ocultar os widgets do fórum.

Melhores cumprimentos,
seender
avatar

seender
Principal contribuidor
Principal contribuidor

Masculino
Inscrito dia : 07/04/2009
Mensagens : 9450
Pontos Ativos : 12457

Ver perfil do usuário http://www.divulgamaisweb.com https://www.facebook.com/Divulga-Mais-Web-874814432638426/

Resolvido Re: Menu personalizado com problema

Mensagem por Kojitani em 25/02/13, 08:20 am

Não deu não Seender
avatar

Kojitani
Nível 9

Masculino
Inscrito dia : 02/02/2013
Mensagens : 173
Pontos Ativos : 257

Ver perfil do usuário http://sobrevivencialistabr.forumeiros.com

Resolvido Re: Menu personalizado com problema

Mensagem por .Danni. em 25/02/13, 08:57 am

Bom dia,

Na gestão do seu widget, onde você pôs os códigos, é só alterar o style da div responsável pelo botão:

Procure isso:
Código:
style="cursor: pointer; height: 17px; width: 17px; border-radius: 4px; -webkit-border-radius: 4px; -moz-border-radius: 4px; position: relative; bottom: -1px; float: right; background: #f5ebf7 url(http://icons.iconarchive.com/icons/kyo-tux/soft/16/Refresh-icon.png) no-repeat 0-13px;"

Substitua por isso:
Código:
style="cursor: pointer; height: 17px; width: 17px; border-radius: 4px; -webkit-border-radius: 4px; -moz-border-radius: 4px; position: relative; bottom: -1px; float: right; background: #f5ebf7 url(http://icons.iconarchive.com/icons/kyo-tux/soft/16/Refresh-icon.png) no-repeat;"

Resulta?
avatar

.Danni.
Membro do Fórum

Feminino
Inscrito dia : 13/01/2010
Mensagens : 1860
Pontos Ativos : 2592

Ver perfil do usuário http://castelobruxo.tk https://www.facebook.com/dannielagoes

Resolvido Re: Menu personalizado com problema

Mensagem por Kojitani em 25/02/13, 09:47 pm

Não resultou. continua com o problema da imagem.
avatar

Kojitani
Nível 9

Masculino
Inscrito dia : 02/02/2013
Mensagens : 173
Pontos Ativos : 257

Ver perfil do usuário http://sobrevivencialistabr.forumeiros.com

Resolvido Re: Menu personalizado com problema

Mensagem por .Danni. em 26/02/13, 04:32 am

Bom dia,

No seu código, tanto CSS quanto o style contido na div do widget, procure:

Código:
background-position: 0px -13px;

E remova o -13 px.
avatar

.Danni.
Membro do Fórum

Feminino
Inscrito dia : 13/01/2010
Mensagens : 1860
Pontos Ativos : 2592

Ver perfil do usuário http://castelobruxo.tk https://www.facebook.com/dannielagoes

Resolvido Re: Menu personalizado com problema

Mensagem por Kojitani em 26/02/13, 09:06 am

Na questão da imagem tá ok - mas, ele agora tá dando um "delay" - quando passa de uma página para outra, o menu inverte e tem que dar reload na página para ficar tudo ok e funcionar direito.

O que acontece? Ele entra aberto e quando pede para fechar - fica a coluna em branco e não recolhe. Quando clica de novo ele recolhe e mostra o painel por cima do fórum - fica desregulado. Se der reload na página fica ok.

Vou por o código aqui - na css não tem nada referente ao painel senão me engano...

Minha css referente ao painel:
Essa é só para alinhar o texto
.postprofile {text-align: center;}
Essa é para padronizar a imagem
.postprofile dl dt a img:first-child {width: 120px; height: 160px;}
Essa é para o quadro
.postprofile{margin-top: 20px;border-radius: 10px;-webkit-border-radius: 10px;-webkit-border-radius: 10px;-moz-border-radius: 10px;float: Right;background: #E1EBF2;border: 2px solid #1675BC;padding: 10px 0;}


Widget tá assim: o bottom eu coloquei -1, mas não influi, porque é só altura dele no fórum. Pus mais perto da margem. O erro que estava dando referente a imagem eu descobri o que era - é que tinha mais '' do que devia. Descobri quando comparei o que voce me mandou com o que tinha no widget - o do tutorial tá com esse erro. Agora tem só essa questão de ele dar essa engasgada de uma página e outra

Do topo
<div id="forum-widget" style="cursor: pointer; height: 17px; width: 17px; border-radius: 4px; -webkit-border-radius: 4px; -moz-border-radius: 4px; position: relative; bottom: -1px; float: right; background: #f5ebf7 url(http://icons.iconarchive.com/icons/kyo-tux/soft/16/Refresh-icon.png) no-repeat;"
onClick="jQuery('#right').animate({width:'toggle',height:'toggle',opacity:'toggle'},1000); if(my_getcookie('forum-widget-http://sobrevivencialistabr.forumeiros.com/')=='0') { my_setcookie('forum-widget-http://sobrevivencialistabr.forumeiros.com/','1',0,0); jQuery('#forum-widget').css('background-position','1px'); jQuery('#content-container div#content').css('margin-right','189px');} else { my_setcookie('forum-widget-http://sobrevivencialistabr.forumeiros.com/','0',1,0); jQuery('#forum-widget').css('background-position: 0px -13px;'); jQuery('#content-container div#content').css('margin-right','17px'); }"></div>

Do fundo
<script type="text/javascript"> jQuery('#forum-widget').insertBefore('#right'); if(my_getcookie('forum-widget-http://sobrevivencialistabr.forumeiros.com')=='0') {jQuery('#right').animate({width:'toggle',height:'toggle',opacity:'toggle'},0); jQuery('#forum-widget').css('background-position','0 0px'); jQuery('#content-container div#content').css('margin-right','0px');} </script>

Do painel
<script src="http://illiweb.com/fa/js_16/collapsible_faq.js" type="text/javascript"></script>

<script>
jQuery(document).ready(function(){
jQuery.get('/profile?mode=editprofile&page_profil=avatars', function(data) {
link = jQuery('.panel dl:first img', data).attr('src');
jQuery('#avatar').attr('src', link);
});
});
</script><center><br/><span style="font-size: 1.2 em;"><font size="2">Seja bem Vindo!<br/>
<img id="avatar" align="middle" width="100%"><font size="2">Convidado</font><br />
</b> 0 mensagens<br/></center>
<span id="friends_cook"></span><br />
</span>

<dl class="faq" style="margin-bottom: -1px !important;"><dt></dt><dd onClick="return CFAQ.display('l7', false);">
<div style="cursor: pointer;" onClick="return CFAQ.display('l7', true);" onfocus="this.blur();"><img src="http://icons.iconarchive.com/icons/saki/snowish/48/Arrow-refresh-icon.png" style="width: 15px;height: 15px" border="0"> Alterar</div></dd><dd style="display:none;" id="l7"><span style="margin: 0pt 0px 0pt 0px; display: block;"><a href="../profile?mode=editprofile&amp;page_profil=informations" target="_blank"> Informações </a></span><span style="font-size: ;">
<a href="../profile?mode=editprofile&amp;page_profil=preferences" target="_blank"> Preferências </a></span><span style="font-size: ;"><br /><a href="../profile?mode=editprofile&amp;page_profil=avatars" target="_blank"> Avatar </a></span></dd><dd onClick="return CFAQ.display('l8', false);">
<div style="cursor: pointer;" onClick="return CFAQ.display('l8', true);" onfocus="this.blur();"><img src="http://icons.iconarchive.com/icons/saki/snowish/48/Arrow-refresh-icon.png" style="width: 15px;height: 15px" border="0"> Ver</div></dd>
<dd style="display:none;" id="l8"><span style="margin: 0pt 0px 0pt 0px; display: block;"><a href="../profile?mode=editprofile&amp;page_profil=friendsfoes" target="_blank"> Amigos e ignorados</a></span><span style="font-size: ;"><a href="../search?search_id=watchsearch" target="_blank"> Tópicos supervisionados </a></span><br /><span style="font-size: ;"><a href="../search?search_id=draftsearch" target="_blank"> Rascunhos </a></span><br /><span style="font-size: ;"><a href="../search?search_id=favouritesearch" target="_blank"> Tópicos favoritos</a></span></dd><dd onClick="return CFAQ.display('l9', false);">
<div style="cursor: pointer;" onClick="return CFAQ.display('l9', true);" onfocus="this.blur();"><img src="http://icons.iconarchive.com/icons/saki/snowish/48/Arrow-refresh-icon.png" style="width: 15px;height: 15px" border="0"> Tópicos e mensagens</div></dd><dd style="display:none;" id="l9"><span style="margin: 0pt 0px 0pt 0px; display: block;"><a href="../msg.forum?folder=inbox" target="_blank"> Mensagens Privadas</a></span><span style="font-size: ;"><a href="../search?search_topics=Convidado" target="_blank"> Meus tópicos</a></span><br /><span style="font-size: ;"><a href="../search?search_id=egosearch" target="_blank"> Tópicos que participo </a></span><br /><span style="font-size: ;"><a href="../search?search_author=Convidado&show_results=posts" target="_blank"> Minhas mensagens</a></span><br /><span style="font-size: ;"><a href="../search?search_id=newposts" target="_blank"> Novas mensagens<br /> <small>()</small></a></span></dd></dl>
<dl class="faq" style="margin-bottom: -1px !important;"><dt></dt><dd onClick="return CFAQ.display('l7', false);"><span class="corners-bottom"><span></span></span>

Estou colocando que, talvez, fique mais fácil para entender se eu que fiz caca em algum lugar ^^

Agradeço a paciência e colaboração.

Parece que foi só na hora que eu atualizei o código, ao que parece esta funcionando corretamente.

agradeço novamente,
Obrigado dado
avatar

Kojitani
Nível 9

Masculino
Inscrito dia : 02/02/2013
Mensagens : 173
Pontos Ativos : 257

Ver perfil do usuário http://sobrevivencialistabr.forumeiros.com

Resolvido Re: Menu personalizado com problema

Mensagem por .Danni. em 26/02/13, 09:55 am

Bom dia,

Você possui outros JS além do que dá o efeito ao painel? Se tiver, tente removê-los e testar seu widget.

Resulta?
avatar

.Danni.
Membro do Fórum

Feminino
Inscrito dia : 13/01/2010
Mensagens : 1860
Pontos Ativos : 2592

Ver perfil do usuário http://castelobruxo.tk https://www.facebook.com/dannielagoes

Resolvido Re: Menu personalizado com problema

Mensagem por Kojitani em 26/02/13, 10:00 am

Por enquanto, tá de boa. Tá dando um delay, vez ou outra. Mas, só atualizar que sincroniza. Eu estou dando uma olhada em outras coisas no momento. Já gravei na memória a dica dos outros js, posteriormente, vou verificar e qualquer coisa eu encho de novo.
Quanto a questão da imagem foi resolvido e o "obrigado" computado ^^
vlws
avatar

Kojitani
Nível 9

Masculino
Inscrito dia : 02/02/2013
Mensagens : 173
Pontos Ativos : 257

Ver perfil do usuário http://sobrevivencialistabr.forumeiros.com

Ver o tópico anterior Ver o tópico seguinte Voltar ao Topo

- Tópicos similares

Permissão deste fórum:
Você não pode responder aos tópicos neste fórum