Configurações

Ver o tópico anterior Ver o tópico seguinte Ir em baixo

Resolvido Configurações

Mensagem por Fastmega10 em 21/12/13, 11:44 am

Qual é minha questão:
Olá a todos,

    Vi alguns tutoriais e decidi coloca-los no meu fórum, tutoriais como: Efeitos no nickname e titulo do tópico completo quando passar o mouse. A primeira vez deu tudo certo, o tutorial funcionou, hoje quando entrei no meu fórum vi que os tutoriais não estavam mais funcionando, resolvi fazer tudo de novo, criar uma nova pagina de JS com o código de cada tutorial novamente, mas ainda assim não voltou a funcionar, as minhas configurações não estão sendo salvas realizei o tutorial certinho, podem me ajudar?Grata.

Atenciosamente.

Endereço do meu fórum:
http://escoladapsicologia.forumeiros.com

Versão do fórum:
PHPBB2
avatar

Fastmega10
Nível 6

Feminino
Inscrito dia : 08/12/2013
Mensagens : 62
Pontos Ativos : 102

Ver perfil do usuário http://forumdoator.forumeiros.com/

Resolvido Re: Configurações

Mensagem por Hancki em 21/12/13, 12:41 pm

Olá!

Realmente isso é estranho! Mudou de versão depois de ter feito a primeira vez, quando funcionou?
Repare que, certamente, cada versão tem um código específico para os efeitos.
De notar que também pode ser um problema de compatibilidade de navegadores.
Refaça tudo, de acordo com a versão do seu fórum. Passe-nos o código usado e depois diga se o problema persiste.

Hancki
avatar

Hancki
Principal contribuidor
Principal contribuidor

Masculino
Inscrito dia : 03/10/2009
Mensagens : 8047
Pontos Ativos : 12032

Ver perfil do usuário http://programacaoweb.forumeiros.com/ https://www.facebook.com/djtomoficial https://www.facebook.com/djtomoficial

Resolvido Já havia mudado

Mensagem por Fastmega10 em 21/12/13, 02:16 pm

Olá Hancki,

Tinha mudado de versão de phpbb2 para o phpbb3 mas depois decidi voltar para o phpbb2, sim já refiz tudo veja os códigos que utilizei:

Título do tópico completo quando passar o mouse:

jQuery(document).ready(function(){p='.forabg .forums .row dd.lastpost';i='.borderwrap .ipbtable td.row1';b='table.forumline td.row3.over span.gensmall';if(jQuery(p).length){t=p}else if(jQuery(i).length){t=i}else if(jQuery(b).length){t=b}else{t='.main-content table.table td.tcr'};jQuery(t+' span a[title]').hover(function(){jQuery(this).attr('alt',jQuery(this).html());jQuery(this).html(jQuery(this).attr('title'))},function(){jQuery(this).html(jQuery(this).attr('alt'))})});

Efeitos no nickname:

jQuery(document).ready(function(){jQuery('a[href="/u1"]:contains("Admin"),span.name strong span strong:contains("Admin")').html('<span style="background: transparent url(http://i46.servimg.com/u/f46/17/36/33/20/pxg8710.gif)"><font color="Cor que deseja"> Admin</font>
</a>')});

Eu uso o google chrome como navegador e os códigos acima já tinha utilizado várias vezes.
Mas são só estes tutoriais que não funcionam.
avatar

Fastmega10
Nível 6

Feminino
Inscrito dia : 08/12/2013
Mensagens : 62
Pontos Ativos : 102

Ver perfil do usuário http://forumdoator.forumeiros.com/

Resolvido Re: Configurações

Mensagem por Hancki em 27/12/13, 11:24 am

Olá de novo!

Usei esses mesmos códigos que deixou na sua resposta e veja o resultado em phpBB2:

Funcionou perfeitamente!
Diga-me como está a fazer para colocar esses códigos em funcionamento. Está colocando nas páginas Javascript?

Hancki
avatar

Hancki
Principal contribuidor
Principal contribuidor

Masculino
Inscrito dia : 03/10/2009
Mensagens : 8047
Pontos Ativos : 12032

Ver perfil do usuário http://programacaoweb.forumeiros.com/ https://www.facebook.com/djtomoficial https://www.facebook.com/djtomoficial

Resolvido Re: Configurações

Mensagem por Fastmega10 em 27/12/13, 03:10 pm

Olá Hancki,

Sim usei-os corretamente, ambos os códigos para cada um criei uma página Javascript , coloquei os códigos e simplesmente salvei, a primeira vez deu certo a segunda vez não deu mais certo.
avatar

Fastmega10
Nível 6

Feminino
Inscrito dia : 08/12/2013
Mensagens : 62
Pontos Ativos : 102

Ver perfil do usuário http://forumdoator.forumeiros.com/

Resolvido Re: Configurações

Mensagem por Hancki em 27/12/13, 03:19 pm

Crie uma nova página javascript, com esses códigos, assim:
Código:
jQuery(document).ready(function(){jQuery('a[href="/u1"]:contains("Admin"),span.name strong span strong:contains("Admin")').html('<span style="background: transparent url(http://i46.servimg.com/u/f46/17/36/33/20/pxg8710.gif)"><font color="Cor que deseja"> Admin</font>
</a>')});
jQuery(document).ready(function(){p='.forabg .forums .row dd.lastpost';i='.borderwrap .ipbtable td.row1';b='table.forumline td.row3.over span.gensmall';if(jQuery(p).length){t=p}else if(jQuery(i).length){t=i}else if(jQuery(b).length){t=b}else{t='.main-content table.table td.tcr'};jQuery(t+' span a[title]').hover(function(){jQuery(this).attr('alt',jQuery(this).html());jQuery(this).html(jQuery(this).attr('title'))},function(){jQuery(this).html(jQuery(this).attr('alt'))})});

No investimento dessa página, coloque para "Todas as páginas", depois salve.

Deu?

Hancki
avatar

Hancki
Principal contribuidor
Principal contribuidor

Masculino
Inscrito dia : 03/10/2009
Mensagens : 8047
Pontos Ativos : 12032

Ver perfil do usuário http://programacaoweb.forumeiros.com/ https://www.facebook.com/djtomoficial https://www.facebook.com/djtomoficial

Resolvido Re: Configurações

Mensagem por Fastmega10 em 29/12/13, 12:52 pm

Olá Hancki,

Novamente não deu certo o código, fiz como pediu.

Agradeço pela ajuda atenciosamente.
avatar

Fastmega10
Nível 6

Feminino
Inscrito dia : 08/12/2013
Mensagens : 62
Pontos Ativos : 102

Ver perfil do usuário http://forumdoator.forumeiros.com/

Ver o tópico anterior Ver o tópico seguinte Voltar ao Topo

- Tópicos similares

Permissão deste fórum:
Você não pode responder aos tópicos neste fórum