Avatar no ultimo que postou não está pegando

Ver o tópico anterior Ver o tópico seguinte Ir em baixo

Atendido / Resolvido Avatar no ultimo que postou não está pegando

Mensagem por GXGamer em 03.03.14 11:24

  • Descrição:
O Avatar No Ultimo Que Postou Não Ta Pegando.

Tutorial Seguido:https://ajuda.forumeiros.com/t70587-tutorial-avatar-do-ultimo-membro-que-postou-no-topico

  • Informações:
Fórum:http://expertcraftsurvival.forumeiros.comVersão:PUNBB
Tipo:Pedido de códigoTags:Avatar,ultimo

GXGamer

GXGamer
Nível 5

Masculino
Inscrito dia : 03/03/2014
Mensagens : 37
Pontos Ativos : 67

http://expertcraftsurvival.forumeiros.com/forum

Atendido / Resolvido Re: Avatar no ultimo que postou não está pegando

Mensagem por Shek em 03.03.14 11:54



Bem-vindo ao Fórum dos Fóruns!
Leia as regras do Fórum dos Fóruns e as regras do setor de suporte.
Antes de criar um tópico, verifique se sua questão já não foi respondida.
Se sua questão foi resolvida, marque-a clicando no botão resolvido para organizar o fórum.
Shek Crowley
Shek

Shek
Admineiro
Admineiro

Masculino
Inscrito dia : 11/04/2009
Mensagens : 18456
Pontos Ativos : 22262

https://shiftactive.blogspot.com https://go.topicit.net/ZosT/61pMt1mPsG https://www.facebook.com/ShiftActif https://twitter.com/ShiftActif

Atendido / Resolvido Re: Avatar no ultimo que postou não está pegando

Mensagem por waghcwb em 17.04.14 22:04

Olá amigo.. Tente este código:
Código:
$(function(){
   $('tbody.statused tr td.tcr').prepend('<div class="avatar-index"><a href="/"><img src="http://i78.servimg.com/u/f78/18/17/62/92/defaul10.png" alt="Avatar"></a></div>');

   $('.avatar-index').each(function(){
      var jUrl    = $(this).parent().children('span').children('a').attr('href'),
         jAvatar = $(this).load(jUrl + 'div.post div.postmain div.postbody div.user div.user-ident div.user-basic-info img:eq(0)').attr('src');

      $(this).children('a').attr('href', jUrl);


      $(this).children('img').attr('src',jAvatar);

   });
});

E isso no CSS
Código:
.avatar-index img{
   background: #FFF;
   border: 1px solid rgb(213, 213, 213);
   box-shadow: 0px 2px 2px rgba(0, 0, 0, 0.1);
   float: left;
   height: 30px;
   padding: 1px;
   width: 30px;
   margin: 5px;
}

Resulta?
waghcwb

waghcwb
Usuário destaque

Masculino
Inscrito dia : 07/09/2012
Mensagens : 734
Pontos Ativos : 1097

http://punbb.forumeiros.com

Atendido / Resolvido Re: Avatar no ultimo que postou não está pegando

Mensagem por Thoth em 26.04.14 0:04

Olá,

Com base em nossas Regras da seção de códigos Javascript & jQuery:

  • Os tópicos com 7 ou mais dias sem uma resposta serão bloqueados, dados como resolvidos e arquivados;

Hoje fazem 8 dias que não há respostas neste tópico, desta forma, estarei a considerar o tópico resolvido.


Atenciosamente,
Equipe Forumeiros!
Thoth

Thoth
Usuário experiente

Masculino
Inscrito dia : 01/11/2011
Mensagens : 2163
Pontos Ativos : 2756

https://tavernanerd.forumeiros.com/

Ver o tópico anterior Ver o tópico seguinte Voltar ao Topo


Permissão deste fórum:
Você não pode responder aos tópicos neste fórum