O formulário não é direcionado ao carregar em "novo tópico"

Ver o tópico anterior Ver o tópico seguinte Ir em baixo

Resolvido O formulário não é direcionado ao carregar em "novo tópico"

Mensagem por SoulKing em 06/02/11, 07:34 pm

Qual é sua questão:
Bem, criei um formulário de postagem com um tópico de Tutoriais e astúcias daqui do fórum. Configurei-o certinho, mas quando clico em Novo Tópico, ele não direciona ao formulário. Antes que perguntem:

- Digitei o ID do fórum corretamente (o ID do fórum é 4);
- Não alterei bruscamente o código.

(PS: O formulário funciona perfeitamente, porém apenas não consigo acessá-lo pelo NEWTOPIC.)

O código segue-se abaixo:

Formulário:

Código:
<script type="text/javascript" src="http://ajax.googleapis.com/ajax/libs/jquery/1.4.2/jquery.min.js"></script>
<script>function radio(nameObtido,valObtido){jQuery('[name="'+nameObtido+'"]').val( valObtido );}
function gerarf() {

}</script>
<form action="/posting.forum" method="post" enctype="multipart/form-data">

<b>Tipo do tópico:</b><br>

<select name="description">
<option value="Sugestão">Sugestão</option>
<option value="Denúncia">Denúncia</option>
<option value="Reclamação">Reclamação</option>
<option value="Dúvida">Dúvida</option>
<option value="Bug/Erro">Bug/Erro</option>
<option value="Elogio">Elogio</option>
<option value="Redeem Code">Redeem Code</option>
<option value="Outros...">Outros...</option>
</select><br><br>

<b>Título do tópico:</b><br><input type="text" name="subject" value="" /><br><br>

<b>Mensagem do tópico:</b><br><textarea name="message" rows="15" cols="50"></textarea><br><br>

<input type="hidden" name="f" value="4" />

<input type="hidden" name="mode" value="newtopic" />
<input type="hidden" name="lt" value="0" />

<!-- Pré Visualizar -->
<input type="submit" name="preview" class="button2" value="Pré-visualizar" ="gerarf();" />

<!-- Enviar -->
<input type="submit" name="post" class="button2" value="Enviar" ="gerarf();" /></form>

JavaScript:

Código:
jQuery(document).ready(function() {
jQuery('a[href^="/post?f=4&mode=newtopic"]').attr('href', '/h1-formulario');
});


Que medidas você tomou para corrigir o problema:
Acho que o erro esteja na descrição do fórum. No tutorial, estava escrito este:

Código:
<script src=-h4.htm></script>

(Claro, já alterado para o ID da página HTML do JavaScript.)

Apresente-nos imagens do problema (se necessário):
Tentei usar meus conceitos em java, mas dei FAIL. '-'
avatar

SoulKing
Nível 2

Masculino
Inscrito dia : 01/02/2011
Mensagens : 7
Pontos Ativos : 16

Ver perfil do usuário http://www.fpsever.forumeiros.com

Resolvido Re: O formulário não é direcionado ao carregar em "novo tópico"

Mensagem por Luciano98 em 09/02/11, 04:44 pm

Tente substituir:
Código:
<script src=-h4.htm></script>
Por:
Código:
<script src="h4-"></script>

E tente substituir:
Código:
jQuery(document).ready(function() {
jQuery('a[href^="/post?f=4&mode=newtopic"]').attr('href', '/h1-formulario');
});
Por:
Código:
jQuery(document).ready(function() {
jQuery('a[href^="/post?f=4&mode=newtopic"]').attr('href', '/h4-');
});

Então me fale se funcionou.
Abraços, Luciano.
avatar

Luciano98
Principal contribuidor
Principal contribuidor

Masculino
Inscrito dia : 01/09/2010
Mensagens : 7648
Pontos Ativos : 11045

Ver perfil do usuário http://ajuda.forumeiros.com

Ver o tópico anterior Ver o tópico seguinte Voltar ao Topo

- Tópicos similares

Permissão deste fórum:
Você não pode responder aos tópicos neste fórum