Problemas ao anexar vídeos no fórum

Ver o tópico anterior Ver o tópico seguinte Ir em baixo

Resolvido Problemas ao anexar vídeos no fórum

Mensagem por Castiiel em 29/01/13, 05:30 pm

Qual é minha questão:
Olá,

Fiz uma busca rápida e encontrei vários tópicos com o mesmo problema e tentei corrigir este problema com as soluções apresentadas nos tópicos, porém sem sucesso.

O que acontece é que quando tento anexar um video do youtube no meu fórum, fica em forma de link, o estranho é que alguns videos dão certo e outros não, fica assim:



Abraços, Castiiel.

Endereço do meu fórum:
http://forumbrazuca.forumeiros.com

Versão do fórum:
PHPBB3

Castiiel
Nível 3

Masculino
Inscrito dia : 15/01/2013
Mensagens : 19
Pontos Ativos : 31

Ver perfil do usuário http://forumbrazuca.forumeiros.com

Resolvido Re: Problemas ao anexar vídeos no fórum

Mensagem por iPrompt em 29/01/13, 07:20 pm

Olá,

Tente utilizar este código JavaScript

Código:
jQuery(function(){jQuery('.postbody a:contains("youtube.com/watch?")').each(function(){a=jQuery(this).attr('href');b=a.split('http://www.youtube.com').join('').split('http://youtube.com').join('').split('/').join('').split('watch').join('').split('?').join('').split('v').join('').split('=').join('').split('&').join('').split('feature').join('').split('feedu').join('');jQuery(this).before("<iframe width=560 height=315 src=http://www.youtube.com/embed/"+b+" frameborder=0 allowfullscreen></iframe><br>")})});

Investimento: Marque " Em todas as páginas "

Até
avatar

iPrompt
Principal contribuidor
Principal contribuidor

Masculino
Inscrito dia : 10/02/2012
Mensagens : 5364
Pontos Ativos : 6851

Ver perfil do usuário http://webskins.forumeiros.com/

Resolvido Re: Problemas ao anexar vídeos no fórum

Mensagem por Castiiel em 29/01/13, 08:41 pm

Sem resultados amigo!

Castiiel
Nível 3

Masculino
Inscrito dia : 15/01/2013
Mensagens : 19
Pontos Ativos : 31

Ver perfil do usuário http://forumbrazuca.forumeiros.com

Resolvido Re: Problemas ao anexar vídeos no fórum

Mensagem por North em 30/01/13, 01:28 pm

Pois é, antes bastava por o link entre as tags e pronto, o vídeo aparecia.. agora está com esse problema.

Alguém sabe explicar o porque isso está acontecendo?
avatar

North
Super usuário

Masculino
Inscrito dia : 07/06/2011
Mensagens : 3836
Pontos Ativos : 5038

Ver perfil do usuário http://ajuda.forumeiros.com

Resolvido Re: Problemas ao anexar vídeos no fórum

Mensagem por -Ruiva em 30/01/13, 02:25 pm

Tente anexar este video, por estes codigos e veja se um desses da certo se sim qual?
http://www.youtube.com/v/mzoCteKn1Bk

Seta larga [youtube] [/youtube]
Seta larga [flash(425,350)] [/flash]
avatar

-Ruiva
Nível 7

Feminino
Inscrito dia : 21/01/2013
Mensagens : 80
Pontos Ativos : 110

Ver perfil do usuário http://garotapopular.forumeiros.com

Resolvido Re: Problemas ao anexar vídeos no fórum

Mensagem por North em 30/01/13, 03:14 pm

Olá,

Veja, pra que funcione é necessário modificar o link do vídeo e usar as tags flash.
https://www.youtube.com/watch?v=eeE9m0hcsMA
https://www.youtube.com/v/eeE9m0hcsMA

Assim funciona, mas isso nunca foi necessário, agora tem de fazer em todos, caso contrário fica como a imagem postada na primeira mensagem.

Café
avatar

North
Super usuário

Masculino
Inscrito dia : 07/06/2011
Mensagens : 3836
Pontos Ativos : 5038

Ver perfil do usuário http://ajuda.forumeiros.com

Resolvido Re: Problemas ao anexar vídeos no fórum

Mensagem por iPrompt em 03/02/13, 12:53 am

Olá,

Tente utilizar este código HTML

<iframe width="640" height="360" src="LINKDOVIDEO" frameborder="0" allowfullscreen></iframe>
Vermelho : Altere pelo o link do vídeo

Até
avatar

iPrompt
Principal contribuidor
Principal contribuidor

Masculino
Inscrito dia : 10/02/2012
Mensagens : 5364
Pontos Ativos : 6851

Ver perfil do usuário http://webskins.forumeiros.com/

Ver o tópico anterior Ver o tópico seguinte Voltar ao Topo

- Tópicos similares

Permissão deste fórum:
Você não pode responder aos tópicos neste fórum