Problema no código

Ver o tópico anterior Ver o tópico seguinte Ir em baixo

Atendido / Resolvido Problema no código

Mensagem por Uatyla em 03.05.14 19:04

  • Descrição:
Pessoal estou com erro no código avatar na ultima postagem, o código aparenta um erro quando não está conectado ao fórum, quando está conectado fica normal, quando está desconectado, aparece a imagem do 1º widget.
Problema no código Rro
Código:
jQuery(document).on('ready', function() {
        jQuery('.topiclist.forums .row .lastpost').prepend('<div class="avat-miembro"><div>');
        jQuery('.topiclist.forums .row .lastpost .avat-miembro').each(function () {
        var profileUserURL = jQuery(this).parent().children('span').children('strong').children('a').attr('href');
        jQuery(this).html('<a href="' + profileUserURL + '" class="avat-miembro-enlace"><img src="Endereço-da-imagem" alt="No Avatar" /></a>');
        jQuery(this).children('a').load(profileUserURL + ' .module:eq(0) img:eq(0)')
        });
        });


  • Informações:
Fórum:http://vidadeaquarista.forumeiros.comVersão:PHPBB3
Tipo:Erros diversosTags:Problema,código



Última edição por uatyla em 03.05.14 21:40, editado 1 vez(es)
Uatyla

Uatyla
Usuário experiente

Masculino
Inscrito dia : 16/05/2012
Mensagens : 2470
Pontos Ativos : 3502

Ver perfil do usuário http://www.vidadeaquarista.com https://www.facebook.com/MinhaVidadeAquarista?ref=hl https://twitter.com/VidadeAquarista

Atendido / Resolvido Re: Problema no código

Mensagem por Hancki em 03.05.14 19:49

Olá!

O código não tem qualquer problema, simplesmente tem que permitir que os convidados vejam os perfis dos usuários!

Hancki
Hancki

Hancki
Principal contribuidor
Principal contribuidor

Masculino
Inscrito dia : 03/10/2009
Mensagens : 8113
Pontos Ativos : 12117

Ver perfil do usuário https://ajuda.forumeiros.com/

Atendido / Resolvido Re: Problema no código

Mensagem por Uatyla em 03.05.14 20:41

Como faço isso sendo o mesmo um JavaScript, eu apenas coloquei em todas as páginas. Em widget é possível...
Uatyla

Uatyla
Usuário experiente

Masculino
Inscrito dia : 16/05/2012
Mensagens : 2470
Pontos Ativos : 3502

Ver perfil do usuário http://www.vidadeaquarista.com https://www.facebook.com/MinhaVidadeAquarista?ref=hl https://twitter.com/VidadeAquarista

Atendido / Resolvido Re: Problema no código

Mensagem por Hancki em 03.05.14 20:51

Não é problema no código! Você tem que autorizar que convidados vejam os perfis dos membros, entende? Só assim o código pode funcionar para os convidados.
Hancki

Hancki
Principal contribuidor
Principal contribuidor

Masculino
Inscrito dia : 03/10/2009
Mensagens : 8113
Pontos Ativos : 12117

Ver perfil do usuário https://ajuda.forumeiros.com/

Atendido / Resolvido Re: Problema no código

Mensagem por Uatyla em 03.05.14 20:57

Mais como faço isso?
Uatyla

Uatyla
Usuário experiente

Masculino
Inscrito dia : 16/05/2012
Mensagens : 2470
Pontos Ativos : 3502

Ver perfil do usuário http://www.vidadeaquarista.com https://www.facebook.com/MinhaVidadeAquarista?ref=hl https://twitter.com/VidadeAquarista
  • 0

Atendido / Resolvido Re: Problema no código

Mensagem por Hancki em 03.05.14 21:04

Siga estes passos: http://prntscr.com/3fvkoa
Deu?

Hancki
Hancki

Hancki
Principal contribuidor
Principal contribuidor

Masculino
Inscrito dia : 03/10/2009
Mensagens : 8113
Pontos Ativos : 12117

Ver perfil do usuário https://ajuda.forumeiros.com/

Atendido / Resolvido Re: Problema no código

Mensagem por Uatyla em 03.05.14 21:39

Resolveu sim!
Uatyla

Uatyla
Usuário experiente

Masculino
Inscrito dia : 16/05/2012
Mensagens : 2470
Pontos Ativos : 3502

Ver perfil do usuário http://www.vidadeaquarista.com https://www.facebook.com/MinhaVidadeAquarista?ref=hl https://twitter.com/VidadeAquarista

Ver o tópico anterior Ver o tópico seguinte Voltar ao Topo


Permissão deste fórum:
Você não pode responder aos tópicos neste fórum